OPC UA server can't browse CODESYS Application

shakir
2020-11-09
4 days ago
  • shakir

    shakir - 2020-11-09

    I have been trying to do CODESYS data encyrption through OPC UA. Regarding that I can connect my Ua Expert or OPC Expert with my CODESYS program through OPC UA server. But the issue I got that OPC server can't browse my CODESYS program application. Did I miss anything? I have tried in so many ways but nothing worked out so far. Attached Ua Expert browsing failure image

     

    Last edit: shakir 2020-11-09
  • MadsKaizer

    MadsKaizer - 2020-11-16

    Could you show your "Symbol configuration" in Codesys? Did you enable the OPC-UA features and also selected the variables with correct permissions?

     
    • shakir

      shakir - 2020-11-16

      Yeah I enabled OPC-UA feature there. I followed the following link:https://help.codesys.com/webapp/_cds_runtime_opc_ua_server;product=codesys;version=3.5.15.0

      I tried in many ways but it didn't work. Atatched my program Symbol Configuration image

       
  • shakir

    shakir - 4 days ago

    Solved the issue. To fix this issue following steps should be taken:

    UAExpert: add the PLC name to hosts file. connect to PLC hostname rather than local Control Win.

    OPCExpert: add the PLC name to hosts file. Add the PLC to the "Network", rather than adding it to "This PC"

     

Log in to post a comment.