Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Problems connecting to Codesys runtime on my Wago PFC200

  • cdutz - 2023-08-26

    Hi all.

    I am currently struggling to get my Wago PFC200 running the Codesys Runtime in version working.

    I am using Codesys V3.5SP19.

    I updated the PFC200 to the firmware version 04.01.10(23) after having tried the latest version (04.03.03(25) from Wago and not being able to start the runtime. After reading version 23 was needed, I changed to that and at least was able to have it start the codesys runtime. I also installed the "Codesys Control for PFC200 SL" plugin for Codesys to install the Codesys runtime in version as well as update the Gateway on the device.

    While I seem to be able to connect to the gateway on the PLC (the dot is green) and when doing a scan, I do now find my PFC200, which is a huge improvement to before, where with firmware version 25 it just failed to start the runtime and I never found any device when doing a scan.

    Unfortunately I don't seem to be able to connect to the PLC in codesys.

    I logged in via SSH and changed the password and I can see that this password is correct as the stuff in the Codesys PFC200 tools tab only works if I use my changed password. And I used those credentials to update the installed Runtime version, which the log claimed to have worked fine.

    Now whenever I try to connect to the device found in the scan, I get a authentication pop-up with empy device name, device address: 000A. As User I use "root" and as password the password that I changed it to.

    As a response I just get "Ungültige Benutzerauthentifizierung auf dem Gerät" (Eng. probably something like "Invalid user authentication on the device".

    What could I be doing wrong? Admittedly I'm a bit lost here :-/


  • eschwellinger

    eschwellinger - 2023-08-26

    I've send out a workaround for this..
    Best Regards

  • cdutz - 2023-08-26

    Turns out I managed to get a connection to my PLC.
    It seems that a few weeks ago Wago released something with version 4.3.3(25).
    So I reset my PLC to Factory-Reset, set it to the IP and changed the IP to the one I wanted with the Wago EthernetSettings tool. Then updated the latest firmware using the WAGOupload tool.

    Now the PLC came back up without a PLC runtime running, so in the Web-tool I wen't to the "Configuration"/"PLC Runtime" and selected the runtime version "CODESYS V3".

    I uninstalled all Codesys versions and installed the version from the download package of Wago together with all the packages the bundle provided.

    After creating a new project I didn't select the old PFC200 runtime, but one of the dozens of new device profiles, that it now listed.

    With these settings I was then able to connect to my PLC.

    Now I hope I'll get the existing project that I had ported to this new structure.

    Sorry for the noise.



Log in to post a comment.