Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Device User Logon

dano8
2021-08-02
2 days ago
  • dano8

    dano8 - 2021-08-02

    I have encountered a bug or maybe I'm doing something wrong here. On codesys 3.5.17 I have created an admin username and password upon first device login as it said I must do. It worked well the first few times logging into the device. However, now when it prompts me to enter my credentials, it doesnt accept them and simply keeps requesting them over and over and over again. So now I cannot download a program to the device and I cannot change communication policy because I cant get logged in as admin. Please help.

     
    • dano8

      dano8 - 2021-08-02

      This is also on a RevPi core III with the revpi driver package and codesys controls for rpi MC

       
  • User

    User - 2021-08-18

    I am also receiving the same issue with a beaglebone black. It happens for the same device across multiple projects. Any help would be greatly appreciated.

     

    Last edit: User 2021-08-18
  • User

    User - 2021-08-19

    I have tried deleting the user management files however the files are not there I've shared what is in that folder. I then tried disabling the user management through the FAQ page with no issue.

    When I try logging into device from scan network I have to enter username and password correctly multiple times, the prompt keeps coming up. After a few tries it works, then when I login for runtime the prompt keeps appearing even if I try to cancel so to get out I have to give the wrong username and password.

    I'm new to codesys and couldn't find anything after searching the forum. Any additional help would be greatly appreciated.

     

    Last edit: User 2021-08-19
  • eschwellinger

    eschwellinger - 2021-08-19

    on which plc are you try to login?

     
    • User

      User - 2021-08-19

      The project I am working on uses Ladder Logic Diagram if that is what you mean

       
    • User

      User - 3 days ago

      I uninstalled and reinstalled codesys which fixed the problem but after a week the same problem occurs again. Im using codesys control for beaglebone black SL. As previously mentioned I don't have the group database or user database files. I have also disabled the (usermanagement: following the guide here https://faq.codesys.com/display/CDSFAQ/Device+UserManagement) but that has not worked either. Any advice would be greatly appreciated. The problem occurs across multiple beaglebone black devices.

       

      Last edit: User 3 days ago
      • eschwellinger

        eschwellinger - 3 days ago

        on your beaglebone it is:
        /var/opt/codesys/
        check with
        ls -A
        -> remove them and disable in cat CODESYSControl_User.cfg
        [CmpUserMgr]
        SECURITY.UserMgmtEnforce=NO

         
        • User

          User - 2 days ago

          Thankyou very much I was able to reset device and only needed to log in once. However I had to search for CODESYSControl_User.cfg on beaglebone and modified it on the beaglebone and on my computer but it still prompted me to enter a new admin and password.

           
        • User

          User - 2 days ago

          Thankyou very much I was able to reset device and only needed to log in once. However I had to search for CODESYSControl_User.cfg on beaglebone and modified it on the beaglebone and on my computer but it still prompted me to enter a new admin and password.

           
  • eschwellinger

    eschwellinger - 2021-08-20

    to which device you try to login, Control Win, Raspberry plc .. ?

     
  • paro

    paro - 2021-09-13

    pfc 200. Could you tell me which files I need to delete here?

     
  • eschwellinger

    eschwellinger - 2021-09-13

    a reset original device - right click in the device tree

     
  • paro

    paro - 2021-09-13

    this action can also be performed only after entering the login data. The password is no longer available. Is there a way without a complete "reset (install FW again)"?

    By the way.. what is the latest FW that supports "CODESYS Control for PFC200 SL 4.2.0.0"?

     

    Last edit: paro 2021-09-13

Log in to post a comment.