Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Codesys Runtime in Raspberry PI 4 falls after just few seconds.

  • kodiac

    kodiac - 2020-09-10

    Hi everyone!
    I'm trying to test the Codesys control on a Raspberry PI 4 with 2 Gb of RAM.
    My problem is that it is only running for a few seconds.
    If anyone had a similar problem please help me.
    Thank you!

  • i-campbell

    i-campbell - 2020-09-10

    Hi kodiac,
    see this thread, in particular the post with the solution https://forge.codesys.com/forge/talk/Runtime/thread/4d43247a3a/#9bcd
    Cheers, Ian

    • kodiac

      kodiac - 2020-09-10

      Thanks i-campbell!
      I will try this.


      Last edit: kodiac 2020-09-10
  • eschwellinger

    eschwellinger - 2020-09-10

    ...and will be solved with 3.5SP16Patch2 release.

    • kodiac

      kodiac - 2020-09-10

      Thank you eschwellinger!
      Please! When will it be released?
      I already tried several alternatives to solve. Of course I'm not an expert on linux, raspberry or codesys but I'm already feeling like an idiot.

      JosΓ© Carlos Rago

    • januar - 2021-06-15

      Hi Edwin,
      We are using 3.5SP16Patch2, but we still have this problem. It is stop after 30 seconds.(code=exited, status=0/SUCCESS) How can we solve this? Is there any way to debug what is the cause of this?
      Thank you in advance.
      Kind regards,

      • eschwellinger

        eschwellinger - 2021-06-15

        use release, then it will work..
        BR Edwin

        • januar - 2021-06-16

          Ok, Thank you Edwin.

  • eschwellinger

    eschwellinger - 2020-09-10

    3.5SP16Patch2 is scheduled for 24th September

    • kodiac

      kodiac - 2020-09-11

      Thank you!

  • selcuke - 2020-09-11

    Hi Everyone,
    I have pi4 8gb and codesys raspberry pi control runtime is stopping after ten seconds or so. I did downgrade with the command as follow, and it worked fine. I will be checking if there is new version, and I will keep it with this verion, won't upgrade. I suggest you better do this for the new patch release.

    sudo rpi-update e1050e94821a70b2e4c72b318d6c6c968552e9a2



  • kodiac

    kodiac - 2020-09-11

    Thank you seculke!
    I don't know if is the same but Codesys people says that the new release of runtime in 24th September will correct this problem


  • Tyro - 2021-06-17

    i had the same issue and got it solved with :
    sudo rpi-update e1050e94821a70b2e4c72b318d6c6c968552e9a2

  • vand3000 - 2022-02-14

    I had the same issue with runtime :
    ii codesyscontrol armhf codesyscontrol based on SDK , from Fri Aug 27 12:04:56 CEST 2021 [121], Release build

    sudo rpi-update e1050e94821a70b2e4c72b318d6c6c968552e9a2

  • markant75 - 2022-02-16

    Hi everyone,
    I had the same issue. The downgrade solved the problem but now I can't use the Pi Touchscreen anymore. After updateing with rpi-update the touchscreen works again and the CODSYS runtime stops again after 20-30 seconds. I checked the log but the last entry was "CODESYS control ready". Anyone having an idea what elso to try ?


  • vand3000 - 2022-02-16

    Hi markant75,
    @eschwellinger Said :
    This problem will be solved with release end of February (24th)

  • vincentger - 2022-02-22


    will the new work with the newest 5.10 kernel?

  • eschwellinger

    eschwellinger - 2022-02-23


  • vincentger - 2022-02-25


    Great! Do you know when this will be released?


Log in to post a comment.