No source code available for profinet library

  • vformanek - 2023-08-23

    Hello, I have been using CODESYS for a while and after updating to version the code randomly stops with this fault.

    Why is that ? I have tried to locate the fault in the Call Stack but I dont know what to do now...

    I have updated the projects properly for the version I am using. This fault started happening after like 14 days of using the new version of CODESYS.


    Last edit: vformanek 2023-08-23
  • Fless

    Fless - 2023-08-23

    looks like you are running in a bug in the newest version 4.4.0 of the profinet library
    or the new library triggers a bug in your code.

    did you update your profinet device too?

    you could try to downgrade to an older version of the library.
    via library manager - placeholders, double click Profinet 4.4.0 in the library column and choose an older version.

    • vformanek - 2023-08-23

      I have tried downgrading and it seems fine now. I am now on version for the library. Mainly the PN controller caused the issue for me. Funny weird is that even the PN controller versions and cause the error. Version works fine.


      Last edit: vformanek 2023-08-23

Log in to post a comment.