Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Add server status: User management needs to be activated.

sarwono
2022-01-01
2022-01-03
  • sarwono

    sarwono - 2022-01-01

    Hello,

    I'm trying to simulate using automation server with 1 devices, the devices can be found when I do network scan, but when I try to add to server it shows status "User management needs to be activated.", thus I cannot add the device to server. Can anyone help?

    Thanks

     
  • eschwellinger

    eschwellinger - 2022-01-01

    which plc do you want to add?
    You need to login to the plc once by CODESYS to set the UserManagement credentials, then you could add the plc to the Automation Server.

     
  • sarwono

    sarwono - 2022-01-02

    Hi,

    I already try to setup the device user management as attached, but the problem still occurred

     
  • sarwono

    sarwono - 2022-01-02

    Hi Edwin,

    I also tried:
    1. activate MFA in automation server
    2. create new fresh PLC device, the error message change as attached but still unable to add the device to server

    Thanks

     
  • eschwellinger

    eschwellinger - 2022-01-02

    Control RTE and CODESYS is in current version..? There you will be asked to add the usermanagement on first login of CODESYS

     

    Last edit: eschwellinger 2022-01-02
  • sarwono

    sarwono - 2022-01-02

    I think yes, I just download it last week
    attached

    where can I check the RTE version?

     
  • eschwellinger

    eschwellinger - 2022-01-02

    now I understand, you try to simulate ? You need to use a real plc - use Control Win 64 on your CODESYS pc- maybe I'm wrong. Just start the plc in the tasktray by rightclick on the plc symbol, then change the project in Codesys by rightclick in the devicetree - update device to Contol Win 64. Then login to this device (you will be asked for add user credential) . After that add this plc to the Automationserver.

     

    Last edit: eschwellinger 2022-01-02
  • sarwono

    sarwono - 2022-01-02

    Yes, I'm trying to simulate the PLC to automation server.
    So does it means I cannot do simulation with automation server if I don't have any real PLC?

    I already update the device to Control Win 64 and start the PLC but the problem still occurred when I try to add the device to server as before

     
  • eschwellinger

    eschwellinger - 2022-01-02

    you need to disable simulation in CODESYS then it will work, start the plc in the tasktray and login to that with CODESYS first..then continue with automation server.

     

    Last edit: eschwellinger 2022-01-02
  • sarwono

    sarwono - 2022-01-02

    I disable the simulation in CODESYS, start the PLC, but when login showed error message as attached

     
  • eschwellinger

    eschwellinger - 2022-01-02

    switch the Gateway to localhost to login to the plc.

     
  • sarwono

    sarwono - 2022-01-02

    already setup to localhost before

     
  • sarwono

    sarwono - 2022-01-02

    sorry forgot attachment

     
  • eschwellinger

    eschwellinger - 2022-01-02

    no just login here by local Gateway, without using the Automation server.

     
  • sarwono

    sarwono - 2022-01-03

    ok already login to gateway-1
    what should I do next so I can connect to automation server?

     
  • eschwellinger

    eschwellinger - 2022-01-03

    on first login that way you will be asked for to add login credentials - these are the one you will be asked on adding the plc to the automation server.
    Either you disable user management or you give the plc the credentials on first login. how to disable them you'll find on - faq.codesys.com

     

    Last edit: eschwellinger 2022-01-03
  • sarwono

    sarwono - 2022-01-03

    it worked, thank you very much Edwin, really appreciate your help

     

Log in to post a comment.