Discussion

FAQ - Frequently asked Questions about CODESYS
FORUM LATEST POST # TOPICS
General Discussion

Forum about anything you want to talk about.

No posts yet 0

Recent Activities

    CODESYS Forge

  • m.prestel m.prestel posted a comment on discussion Deutsch 🇩🇪

    Hey, erst einmal sollte SP17 Patch X keinen Unterschied machen. Die Visu ist nun ein separates Adddon, welches seinen eigenen Release Zyklus hat. Die aktuell freigegebene Version ist 4.1.1.0. Wenn du meinst, dass das ein Fehler ist und das das schon mal ging, dann melde den Fehler bitte über den Store mit einem vereinfachten Beispielprojekt und genauen Schritten, um den Fehler nachzustellen. Natürlich musst du dich aber auch fragen, wieso du die LOWER und UPPER Bound über ein Array machst und nicht...

  • jgardner jgardner posted a comment on discussion Engineering 🇬🇧

    I am not using The Visual Elements library in my code at this moment, so I don't know why the compiler keeps throwing me this warning. How can I get rid of this warning?

  • mg0815 mg0815 posted a comment on discussion Deutsch 🇩🇪

    ZUMINDEST BIS ICH DER MEINUNG, DASS DAS EIN FEHLER IST, ABER VIELLEICHT SIEHT DAS JEMAND ANDERS Dieser Fehler taucht seit V 3.5.17.2 auf. Wenn ich ein ARRAY erstelle (siehe 2.)und die Limitierung der Anzahl der Variablen als Konstante definiere (siehe 1.) funktioniert das einwandfrei bis ... Ich dieses Array als Tabelle in der Visu darstellen will (siehe 3.) Dann kommt es beim Übersetzungsaluf zu der Fehlermeldung (siehe 4.) Es wird folgender Fehler ausgegeben [FEHLER] ****: _MAIN Device: SPS-Logik:...

  • AlexD AlexD posted a comment on discussion Runtime 🇬🇧

    Hi! I was able to download the project, there was a device description vs runtime mismatch, - runtime 3.5.15.30 - project 3.5.16.0 (no warning at download!) Runtime was updated after second attempt (/opt/janztec/watchog folder delete error) Hope no more faults, fingers crossed

  • jreitzig jreitzig posted a comment on discussion Runtime 🇬🇧

    Hi. thanks for your replies....This was a "layer 8 problem". Still not knowing how I got in and out of this mess I am now back on track... Just two last questions (taking this thread totally off-topic:-( ): 1) The icons for modbus do not turn green but are operational... any deeper meaning to this ? 2.) If this is related to the demo license (for raspberry), do I also need an additional license for ModBus ? The logs let me assume this: Demo mode for Modbus/TCP Master started. Thank you

  • i-campbell i-campbell posted a comment on discussion Runtime 🇬🇧

    looking at the release notes, there was a bump to debian 11 https://downloads.raspberrypi.org/raspios_armhf/release_notes.txt just adding some info, not a solution though. I dont suppose they added a default firewall pr something?

  • jreitzig jreitzig posted a comment on discussion Runtime 🇬🇧

    Hi. Just a fresh reinstall of the latest RPI OS. The CodeSys runtime is 4.2.0.0 logs. It seems the device error is gone, yet I still can no longer get the modbus tcp conncetion to work. Even though the logs seem to indicate that the slave (192.168.100.106) is the root of the issue, I can assure that not a single byte is crossing the wire in neither direction as I am checking via tcpdump/wireshark using display filters for mbtcp. It all worked flawlessly until 2 days ago and now I am getting the error...

  • fschneider fschneider modified a comment on discussion Deutsch 🇩🇪