Personal Data

Username:
patrickrjbrown
Joined:
2019-10-30 14:20:44+00:00
Location:
Newport / Britain (UK) / GMT
Gender:
Male

Projects

  • No projects to display.

Skills

  • No skills entered.

User Activity

  • Posted a comment on discussion Motion πŸ‡¬πŸ‡§ on CODESYS Forge

    Morning Codesys'ers quick question... i've never seen this before.. but i've started getting a HWlimit error i suspect its from having been trying to improve the tuning using the Omron CX drive software and i've set a setting.. but does anyone know how i can work around this... thanks Pb

  • Posted a comment on discussion Motion πŸ‡¬πŸ‡§ on CODESYS Forge

    some time later... (in the words of sponge bob) i'm back ... its all been sort of working.. and like all good projects that are 80% done.. you start using them ..... and thats been the case.... so untill the shaft that connected the machine to the servo broke... it was all good... so now... here we are... and i'm not even sure if this is a good idea tagging this onto an existing thread... but does anyone have any more experience of using a Ethercat drive with a raspberry pi... as there is one little...

  • Posted a comment on discussion Motion πŸ‡¬πŸ‡§ on CODESYS Forge

    now if i was smart.. i'd look at what i was doing when i started... so looking at the early pictures of the project you can see i'd actualy started with it right.. but managed to get it more wrong.. anyway .. i've just had a issue with the comms loosing sync.. so i might need to tweek the settings a bit, before its perfect.. Pb

  • Posted a comment on discussion Motion πŸ‡¬πŸ‡§ on CODESYS Forge

    and as if by magic.. Eschwellinger has the answer.. so ... from what i can tell its not as simple as just doing what i did.. which was do a scan on the ethercat bus, add it to the project, and then add a generic DS402 softmotion device.. oh no... so .. i needed to pay attention to the icons.. there is one that looks like a grey computer box.. and when i searched down in the list i found one that matched the servo drive.. so if you do an "update device" to that.. you get grey computer box icon.. (which...

  • Posted a comment on discussion Motion πŸ‡¬πŸ‡§ on CODESYS Forge

    many many moons ago.. I started this... and I've been super busy on trying to get it sorted.. and thats led me down the path of getting to know what I'm doing.. and how things should work.. and well.. like always.. time goes by.. and things get pushed in front of other things.. but anyway .. I took a look at it today .. but using the code from a much better coder than me.. (his youtube channel is called "black" https://www.youtube.com/channel/UCeOa8aEiV8CdAO9dCp7PATA (this should be the link to the...

  • Posted a comment on discussion Engineering on CODESYS Forge

    WOW... thats massive.. and also important to know.. so let me just check what that looks like.. (for my own sanity .. and to see if i understand what your talking about.. ) if you have some program code that uses a function block to control a servo over ethercat, like Power_on, or the Jog function block.. that code needs to be running under the Ethercat Task in the task configuration part of the devices tab in codesys.. like in this picture.. so by doing this you are getting the ethercat "driver"...

  • Posted a comment on discussion Engineering on CODESYS Forge

    My progress has been patchy... I can get the drive to go online, and it looks to be handling the ethercat traffic, I get drive feedback, and if you command the drive it shows as busy, but no motion, I have tried all the scaling options I can think of... But nothing seems to help, the frustration is the drive is fully working from CX drive or the config mode... It's clearly something in a config somewhere Pb

  • Posted a comment on discussion Motion on CODESYS Forge

    I just saw that the device was a slave... So indeed that might not help... I think I will upgrade the pi at some point, but I do worry a little about how the codesys runtime licence transfer works... So I want to test that first... On On Sat, 1 Aug 2020, 05:50 eschwellinger, forge@codesys.com wrote: Hi, Usually this is mit a problem, USB or internal Ethernet Interface. Both work like charm as long you do mit mix up ethercat and other TCP/ip ethernet devices. Die Softmotion the important thing is...

View All