Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

PCAN USB 'No Driver Found'

vbelo
2015-06-29
5 days ago
  • vbelo

    vbelo - 2015-06-29

    Hello,

    I am working on a CAN diagnostic software tool that uses a PEAK PCAN USB network monitor as the interface into the CAN network. The software builds and compiles and I am able to login to the PLC (using the computer as a PLC for now). Im using 'CoDeSys_Control_Win_V3' runtime and have added a CANbus Device to my project. Upon logging in and selecting the Status Tab on the CANbus device, I see 'No driver found'. I'm guessing this is some sort of configuration issue or setting within my project that has to point to the PCAN USB driver installed on my computer. Can somebody tell me where the driver should be placed so that CoDeSys 3.5 could use it?

    Things I have done:
    Confirmed the PCAN module is working correctly (read, write, and filter functions work as intended)
    Added a CANbus deivce in CoDeSys
    Started the PLC Control in the windows taskbar
    Modified the CODESYSControl.cfg file in the installation directory\GatewayPLC (uncommented Componenet.6=CmPUSBCanDrv)
    Added the PCAN_USB.SYS file into \GatewayPLC\Driver Folder. (was already there, but I over wrote it again)
    Checked for no conflicting baud rates or node ids

    CANbus Device Information Tab:
    Type 15
    ID 181015
    Version 3.5.4.0

    What am I missing?

    Thank You,
    Vadim B.

     
  • eschwellinger

    eschwellinger - 2015-06-29

    Hi,

    if you use current CODESYS Version (V3.5.6.x) and you add

    [ComponentManager]
    Component.1=CmpTargetVisuStub
    Component.2=CmpCodeMeter
    Component.3=CmpWebServer
    Component.4=CmpWebServerHandlerV3
    Component.5=CmpPCANBasicDrv

    to the "c:\Program Files\3S CODESYS\GatewayPLC\CODESYSControl.cfg"
    it will work like a charm
    Even using several Peak-USB adapter connected (several CAN bus) are possible and doing CAN View at the same time while the runtime is running will work.

    BR
    Edwin
    PS: this is a CODESYS V3 question... will be moved to the CODESYSV3 section

     
  • Anonymous - 2015-09-29

    Originally created by: OW_RPi

    Hello,

    I want to use my PEAK CAN USB dongle with 'CoDeSys Control Win V3'.
    I followed Edwin's instructions and added 'Component.5=CmpPCANBasicDrv' to '\\GatewayPLC\CODESYSControl.cfg'.
    But when start my application, CANBus Status shows ' No driver found'.

    Is there anything I forgot?

    Next question: Is it possible to use PEAK CAN USB dongle with 'Condesys Control for Raspberry Pi'?

    Please help!

    Best regards,
    Oleg

     
  • eschwellinger

    eschwellinger - 2015-09-29

    Hi Oleg,

    please check on runtime startup (in the plc logger) if
    CmpPCANBasicDrv component is loaded without error.

    PeakUSB with Pi:
    If you compile the Pi Linux kernel with socket can and enabled Peak USB modules, this should work.
    Maybe the Peak System Forum give here more details:
    http://www.peak-system.com/forum/viewto ... a&start=60

    BR
    Edwin

     
  • travlytle

    travlytle - 2016-09-13

    I can't get this to work either using Codesys V3.5 SP9 Patch 2 (US) + for Control Win V3.

    Here is my CodesysControl.cfg

    [ComponentManager]
    Component.1=CmpTargetVisuStub
    Component.2=CmpDynamicTextUS
    Component.3=SysCpuMultiCore
    Component.4=CmpHilscherCIFX
    Component.5=CmpPCANBasicDrv
    ;Component.4=CmpBlkDrvCanServer

    The log shows CAN0 (DEVICE_NUMBER = 0): NetID = 0 CmpPCANBasicDrv

    When I go online, the CANBus Status says "No driver found"

    This is just using the demo version, could this be why?

    Thanks,
    Travis

     
  • eschwellinger

    eschwellinger - 2016-09-13

    Hi,
    No should even work with demo version!
    Could you give us the whole logger
    Start Control Win by console (run as admin) and /debug option for a test.

    BR
    Edwin

     
  • cole

    cole - 2022-03-28

    Hello,
    I have "No CAN driver found! (error code: 16#27E2)"

    I have added "

    [ComponentManager]
    Component.1=CmpPCANBasicDrv

    " to my CODESYSControl.cfg in GatewayPLC folder.

    I have Control Win V3 Version 3.5.17.0 running and when I scan, I find my local PC and am able to login and download.

    I have PCAN-View running, I've tried without it running as well. I also contacted Peak and they mentioned drivers, I have them installed, I use PCAN-View and PCANApi almost every single day.
    What else could I be missing? I have also attached a log.

     

    Last edit: cole 2022-03-28
  • eschwellinger

    eschwellinger - 2022-03-29

    I could not see that the CmpPCANBasicDrv is loaded on startup of the plc:

    In SP17 Control Win configuration should be this:
    c:\ProgramData\CODESYS\CODESYSControlWinV3x64\<uniquenumber>\CODESYSControl.cfg </uniquenumber>

    [ComponentManager]
    Component.1=CmpTargetVisuStub
    Component.2=CmpWebServer
    Component.3=CmpWebServerHandlerV3
    Component.4=SysCpuMultiCore
    Component.5=SysReadWriteLock
    Component.6=SysCpuBreakpoints
    Component.7=SysPipeWindows
    Component.8=CmpPCANBasicDrv

     

    Last edit: eschwellinger 2022-03-29
  • cole

    cole - 2022-03-29

    What other steps are needed? I have now added CmpPCANBasicDrv to C:\ProgramData\CodeSys\CODESYSControlWinV3\F05D572C as well as in the GatewayPLC folder as mentioned above.

    I also tried uncommenting net 0 in CmpBlkDrvCanServer.

     
  • alez

    alez - 6 days ago

    I have the same problem but , even if I modified the CODESYSControl.cfg with Component.X=CmpPCANBasicDrv , in log file doesn't appear CmpPCANBasicDrv.

    Is there something wrong in my configuration?

     
  • eschwellinger

    eschwellinger - 6 days ago

    Is sure that you are in the correct CODESYSControl.cfg file could you add it?

     
  • cole

    cole - 6 days ago

    I had added my CODESYSControl.cfg. Is it the right file? Correct contents? Do you need a license or something else to make this work?

     
  • eschwellinger

    eschwellinger - 6 days ago

    no licenses needed, but where is the CODESYSControl.cfg is located?

     
    • alez

      alez - 5 days ago

      this is the path of CODESYSControl.cfg file : C:\Program Files\CODESYS 3.5.17.10 (64bit)\GatewayPLC\tempCFG

      the file is attached

       
  • cole

    cole - 5 days ago

    Hi Edwin, could you please post an example.projectarchive and a CODESYSControl.cfg with the location/path to place it? Then we could simply open the archive and compare the CODESYSControl.cfg to our own/replace ours to get this working. In this example project that runs on a Windows machine, could you please have it sending and receiving a CAN message?

     
  • eschwellinger

    eschwellinger - 5 days ago

    Can example is here in forge or store: https://store.codesys.com/de/catalogsearch/result/?q=can+example
    the location of your config file on using Control Win 64Bit is:
    c:\ProgramData\CODESYS\CODESYSControlWinV3x64\xxxxxxxx\CODESYSControl.cfg

     

    Last edit: eschwellinger 5 days ago

Log in to post a comment.