Serielle Schnittstellen mit CAA SerialCom Library öffnen

Deutsch
Nabi
2020-02-10
2020-02-13
  • Nabi

    Nabi - 2020-02-10

    Hallo,
    ich habe Probleme mit dem Öffnen meiner Seriellen Schnittstellen. ich benutze die FBs der CAA SerialCOM Library 3.5.15.0.

    An Hardware habe ich 750-8202, 2x750-430, 750-530, 750-650 und einen Busabschluss zusammen gesteckt.

    Nun möchte ich die seriellen Schnittstellen nutzen. Im WBM habe ich die serielle und die Service Schnittstelle auf Unassigned gestellt. Also auf die Benutzung durch Libraries.

    Ich habe die Parameter Deklaration erstellt wie sie in der Doku zur Library stehen.

    XX_OW_OPON: BOOL;   // Serial Interface einschalten
    XX_OW_COM : ARRAY [1..7] OF COM.PARAMETER := [
        (udiParameterId := COM.CAA_Parameter_Constants.udiPort,             udiValue := 0),
        (udiParameterId := COM.CAA_Parameter_Constants.udiBaudrate,         udiValue := 9600),
        (udiParameterId := COM.CAA_Parameter_Constants.udiParity,           udiValue := 2),
        (udiParameterId := COM.CAA_Parameter_Constants.udiStopBits,         udiValue := 0),
        (udiParameterId := COM.CAA_Parameter_Constants.udiTimeout,          udiValue := 0),
        (udiParameterId := COM.CAA_Parameter_Constants.udiByteSize,         udiValue := ,
        (udiParameterId := COM.CAA_Parameter_Constants.udiBinary,           udiValue := 1)];
    XX_OW_LENG : USINT := SIZEOF(XX_OW_COM)/SIZEOF(COM.PARAMETER);
    

    Und im meinem CFC nutze ich den FB COM.Open .

    Wenn ich als Port die 0 eintrage, bekomme ich beim öffnen die Rückmeldung unbekannter Fehler.

    Trage ich für Port eine 1 ein bekomme ich keinen Fehler.

    Trage ich als Port eine 2 ein, das sollte jetzt die 750-650 Karte sein, bekomme ich wieder unbekannter Fehler.

    Ich habe drei Bildschirmkopien angehängt die das zeigen.

    Zum Schluss sei noch gesagt dass diese Hardware unter WAGO I/O Pro, Serial_interface_01.lib und Hyperterminal funktioniert. Und lange ASCII-Texte überträgt.

    Also denke ich, dass es an den Parametern liegt. Habe aber keine Idee wie ich da weiter komme. Wäre nett wenn mir einer Tipps geben könnte.

    IMG: Serialinterface

    IMG: Serialinterface

    IMG: Serialinterface

     
  • eschwellinger

    eschwellinger - 2020-02-11

    Hi,
    ich versuch es mal zu erklären,
    aktuell werden von SysCom und CAA Serial Com nur die Ports unterstützt die auch im Linux des PFC's
    als normale Com ports verfügbar sind.
    Sprich nur den vorne auf dem Gerät und vermutlich könnte man auch den Service Port dazu verwenden.
    Diese KBUS Modul Comports sind nur übers Prozessabbild eingebunden dafür gibt es aktuell
    keinen Treiber / Lib von uns.
    Es gibt Bibliotheken von Wago mit der man diese Module über eine Klemme ( also Feldbus dazwischen) ansprechen kann
    dafür musst du aber beim Wago Support anfragen ( bin auch nicht sicher ob und wie das dann geht wenn man die Bibliotheken hat)
    Es gibt ein PDF dazu: Anwendungshinweis_Fremdsteuerung_mit_CoDeSysV3.pdf das wäre dein Use Case.
    Wäre toll wenn du deine Erfahrungen mit uns teilen könntest.
    Grüße
    Edwin

     
  • Nabi

    Nabi - 2020-02-13

    Hallo Edwin,

    ich habe alles Mögliche versucht an diese Dokument zu kommen. 'Anwendungshinweis_Fremdsteuerung_mit_CoDeSysV3.pdf ' Leider ohne Erfolg. Könntest du mir einen Link darauf geben oder das Dokument selbst?

    Gruß
    Nabi

     
  • eschwellinger

    eschwellinger - 2020-02-13

    Hi,
    Hast du beim Wago Support angefragt?

    Grüsse
    Edwin

     
  • Nabi

    Nabi - 2020-02-13

    Hallo,

    nein das habe ich noch nicht getan, da ich zuerst diese Dokument lesen wollte.

    Gruß
    Andreas

     

Log in to post a comment.