Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

K-Bus Klemme an Ethercat Slave einbinden. Gerät konnte nicht hinzugefügt werden.

2021-11-27
2021-11-28
  • one-happy-teddy

    one-happy-teddy - 2021-11-27

    Hallo Zusammen,

    ich habe mir in eBay eine BK1250 (Buskoppler EtherCat auf K-Bus) und ein paar andere Beckhoff K-Bus Klemmen ersteigert. Ich habe diese an einen EK1100 gesteckt, mittlerweile alle möglichen Geräte-Repos installiert und versuche über „Geräte suchen“ die Klemmen in mein Projekt einzubinden.

    Die Klemmen werden auch wunderbar erkannt, wenn ich diese allerdings hinzufüge kommt bei jeder einzelnen die Meldung „Das Gerät Klemmenbezeichnung konnte nicht hinzugefügt werden.“ Nur der BK1250 lässt sich hinzufügen.

    Ich benutze CODESYS V3.5 SP17 + auf einem Raspberry Pi 4B, ich habe den EhterCat auf dem eth0 aber auch schon ein USB-LAN Adapter und somit den eth1 ausprobiert.

    EL Klemmen werden an diesem EK1100 Modul erkannt und Funktionieren einwandfrei.

    Weiß jemand was ich falsch oder nicht mache oder wo das Problem sein könnte?

    Danke für eure Hilfe!
    Viele Grüße, Hannes

     
  • one-happy-teddy

    one-happy-teddy - 2021-11-28

    Hallo Edwin,

    danke für die schnelle Antwort :)
    Ich habe nun heute die MDP Files installiert, alle alten ESI Files rausgelöscht, neu eingefügt, hab eine Odysee an Codesys Neuinstallation hinter mir und finally hab ich die Klemmen von Hand einfügen können. Es funktioniert nur nicht. Der Bus läuft nicht. Habe auch schon die Sprache auf Englisch gestellt wie in dem anderen Post beschrieben. Ich komm nicht mehr weiter und mir raucht der Schädel :)
    Vielleicht hast ja du noch eine Idee?

    Viele Grüße, Hannes

     

Log in to post a comment.