Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Codesys Setup hängt

byt0x
2023-01-02
2023-01-02
  • byt0x

    byt0x - 2023-01-02

    Hallo,

    eigentlich habe ich beim Setup schon immer Probleme. Aber irgendwie hat es dann immer nach langer Zeit und zufälligem Rumgeklicke im Setup-Fenster funktioniert.

    Jetzt geht garnichts mehr.
    Es hängt immer bei "Install all Packages added to the setup.".

    Es ist auch ein Problem was an verschiedenen Computern besteht und es geht nich tnur mir so und das auch schon länger. Es gibt hier im Forum bereits einen Topic dazu, jedoch ohne Lösung. Defender habe ich auch mal deaktiviert und ich installierte auch mal mit Adminrechten.

    Ich habe versucht es zu installieren mittels:
    1. Setup File
    2. Ungepacktes Setup
    3. Über die Konsole ("CODESYS 3.5.18.0.exe" /v"/L* Setuplogfile.txt")

    Kann mir bitte jemand sagen was ich tun kann?

    MG

     
  • h-hermsen

    h-hermsen - 2023-01-02

    Hallo,

    Mein Deutsch ist verrostet aber ich probiere es einmal. Ich vermutte das deine setup schon functoniert. Installation des packages dauert immer ein lange weile. Probiere es mit dem normale Interactive setup (nicht via CLI). Denn muss es auch functionieren und kann mann nachdem das via CLI ausprobieren.

    Good luck!

    PS update CODESYS installer auch selbst nach neuestem version.

     

    Last edit: h-hermsen 2023-01-02
  • h-hermsen

    h-hermsen - 2023-01-02

    Note to self: POST nur eine mahle drucken.

     

    Last edit: h-hermsen 2023-01-02
  • byt0x2

    byt0x2 - 2023-01-02

    Danke für die Rückmeldung.

    Habe ich so alles ausprobiert. Es hängt immer bei "PackageManagerCLI.exe" und immer beim ersten Paket (siehe Log).


    I've already tried all this possibilities. But everytime it hangs while installing the first package by "PackageManagerCLI.exe". It's visible in the log file. The TaskManager shows, that the process is working with ~7% CPU Usage and 100MB RAM. But also after an hour, there is no progression.

     
  • eschwellinger

    eschwellinger - 2023-01-02

    nimm doch bitte die Version 3.5.18.40

     

    Last edit: eschwellinger 2023-01-02
    • byt0x2

      byt0x2 - 2023-01-02

      Ich habe nun nochmal von Hand alles gelöscht und mit deaktiviertem Defender geschafft es zu installieren.

      Die aktuellste würde ich gerne nehmen, wenn sie denn mein bestehendes Projekt öffnen könnte.
      Leider habe ich hier das Problem das mir immer angeboten wird eine ältere IDE runterzuladen (mit selben Ergebnis) oder das Projekt trotzdem zu öffnen - was mir dann aber das Projekt zerschießt.

      Also, es geht nun. Aber wieder: Man weiß nicht warum.

       
  • andrax

    andrax - 2023-01-02

    Ich glaub, das Problem liegt weniger am Codesys-installer.
    Hast du schon deine Systemereignisanzeige durchforstet? >> "eventvwr"

     
    • byt0x2

      byt0x2 - 2023-01-02

      Habe da grob reingesehen auf dein Anraten hin, weiß aber nicht wo ich da anfangen soll mit suchen. Mir fehlt da der Faden.
      Ich habe auch gerade den PC neu aufgesetzt und bestimmt 30 Programme installiert (auch mit MSI) und nirgends Probleme gehabt.

      Wie gesagt, war auch nicht das erste Mal. Bei der 3.5.18.40 bin ich mir jetzt nicht sicher ob ichs da schon hatte weil ich mit der 3.5.18.0 angefangen hatte.

       
  • eschwellinger

    eschwellinger - 2023-01-02

    wenn es das Projekt zerschießt wuerde ich das gerne anschauen..

     
    • byt0x2

      byt0x2 - 2023-01-02

      Klar gerne. Es ist in dem Fall ein privates Projekt für das RaspberryPi Runtime (ka wie groß da die Ambitionen sind).

      Ich schicks gleich pper PM hier im Forum.

       
  • eschwellinger

    eschwellinger - 2023-01-02

    Das geht bei mir.Ich öffne mit 3.5.18.40 - klar CODESYS schlägt vor es mit genau der Version zu öffnen wie es erstellt wurde - aber das willst du ja nicht, du willst ja alles in aktuellster version - also einfach öffnen, dann wird man nach update von Bibliotheken - Compiler Version gefragt - ja alles aktualisieren und schon ist das Projekt in 3.5.18.40.

     
  • byt0x2

    byt0x2 - 2023-01-02

    Dann lag es ggf an 64Bit.
    Ich probiere es nachher.

     

    Last edit: byt0x2 2023-01-02
  • eschwellinger

    eschwellinger - 2023-01-02

    nein.. immer 64Bit nehmen!

     

Log in to post a comment.