Rasberry 4 und Codesys 3.5.16

Deutsch
thommi54
2020-08-17
2020-08-21
  • thommi54

    thommi54 - 2020-08-17

    Hallo,
    ich verzweifle gerade an einem neuen Raspberry 4 und an Codesys 3.5.16 . Ein Testprojekt vom Raspberry 2b und Codesys 3.5.14 geht erst mal nicht einfach los auf dem Raspberry 4 (MQTT+Oscat wollen nicht, Modbus will nicht alles u.ä.).

    Jetzt habe ich mal die Compilerversion und das Visualisierungsprofil auf 3.5.14 zurückgestellt (innerhalb 3.5.16) und es funktioniert auch nicht. Nun sehe ich mich meist selbst als das Problem an und hatte gedacht mit 3.5.14 müsste alles laufen. Ist dieser Gedanke richtig? Oder ist am Raspberry 4 an der Installation noch was zu tun ?? Beim Übergang vom Raspberry 2 zum Raspberry 3 kann ich mich dunkel an solche Zusatzeinstellungen erinnern.

    Gibt es für den Raspberry 4 etwas am Betriebssystem einzustellen.
    Gibt es eine Installationsanweisung für den Raspberry 4?

    Für Hinweise bin ich wie immer dankbar.
    Mfg
    Thomas

     
  • thommi54

    thommi54 - 2020-08-18

    Hallo Edwin,
    Ich muss das Problem erstmal in "Pi4" und dann in "3.5.16" trennen.
    Wenn ich das richtig verstehe, müsste der Pi4 mit der 3.5.14 einfach losgehen... ???

    Mfg
    Thomas

     

    Last edit: thommi54 2020-08-18
  • eschwellinger

    eschwellinger - 2020-08-18

    Nein...Pi4 geht nicht mit SP14...nimm SP16Patch1 allem denn wird's gehen ( nur halt nicht mit apt-get im OS die neuesten Updates installieren)
    Grüsse
    Edwin

     
  • thommi54

    thommi54 - 2020-08-20

    Hallo,
    nun ist das Service-Pack 1 installiert und das nächste Problem quält mich. Es gibt unter "Tools" kein "Update Raspberry" mehr (Bild Update_Rasp_1.jpg). In einer parallelen 3.5.11-Installation gibt es das noch. Aber ob die richtige "runtime" von 3.5.11 auf den Pi4 hochgeladen wird und gestartet ist eine Frage.

    Was kann ich denn dagegen tun ?? Die Installation 3.5.16.0 hatte den Updatepunkt noch.

    Viele Grüße
    Thomas

     

    Last edit: thommi54 2020-08-20
  • eschwellinger

    eschwellinger - 2020-08-21

    Dann nochmal das Pi Package über das Einkaufswagen Icon aus dem Store nachinstallieren und CODESYS dann neu starten
    ...wenn du das schon hast und es kommt nicht über Tools customize das Menü Kommando manuell hinzufuegen

     

    Last edit: eschwellinger 2020-08-21
  • thommi54

    thommi54 - 2020-08-21

    Hallo Edwin,
    der Hinweis hätte bestimmt geholfen, aber ....
    Im Bild ist aus meiner Sicht erkennbar, daß hier was im Argen liegt. Im Codesys 3.5.16.10 (Patch 1) erscheint unter"Tools" ein Fehler und auch keine Zeile mit "Update Raspberry". Zum Vergleich habe ich eine 3.5.11 angezeigt im Anhang.

    Und zu meinem Verständnis: unter "Pi Package" meinst Du die "CODESYS Development System V3 (3.5.16.10)" ?? Das habe ich schon nachinstalliert.

    Grüße
    Thomas

    Update: Hat sich alles in Wohlgefallen aufgelöst. Das Package ist natürlich NICHT die Entwicklungsumgebung,sondern "CODESYS Control for Raspberry Pi SL". Diese unterschiedlichen Begrifflichkeiten sind nichts für ältere Herrschaften...

    "Update Raspberry" ist jetzt unter "Tools" auch wieder zu fnden.

     

    Last edit: thommi54 2020-08-22

Log in to post a comment.