Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

The "Download missing libraries" feature stopped working

Yegor
2015-12-07
2015-12-10
  • Yegor

    Yegor - 2015-12-07

    Why did the "Download missing libraries" feature stop working?

    I've tried visiting those URLs in a browser and they all seem to be "Forbidden".

    Why? How do I get my project working now?

    IMG: missing.png

    IMG: forbidden.png

     
  • RolandWagner

    RolandWagner - 2015-12-07

    This must be an issue of Firewall Settings or other protections methods. I just tried it again myself and it worked properly. A direct access to the URL is not intended.

     
  • Yegor

    Yegor - 2015-12-07

    Well, I've disabled firewalls on two different PCs (Win8/Win10) and tried two different ISPs. Still, it shows "Download failed" after "Pending..." for about 1 sec. Could that be an older version (mine is 3.5 SP5) issue? Should I try updating it?

     
  • Yegor

    Yegor - 2015-12-08

    Ok, this looks like some security-related issue with encryption, certificates and other stuff. The easiest workaround is to disable secure connections to CoDeSys Store in the AppData/Roaming/CoDeSys/CoDeSys.opt file by replacing https://store... with http://store...

    I'm not sure what causes it on my side as I've tried three different PCs (including one laptop that I know worked fine in September and wasn't touched since then until today) and two different ISPs.

    What makes me really suspicious of problems on the server side is this warning in Chrome:

    Also, the Fiddler app somehow makes the "Download missing libraries" feature work when set to decrypt (recrypt?) HTTPS traffic. So, that's another workaround.

    And by the way, here's how unsuccessful download attempts look in Wireshark:

    IMG: security.png

    IMG: wireshark.png

     
  • eschwellinger

    eschwellinger - 2015-12-08

    Hi,
    thank you for reporting this!
    We will solve this a.s.a.p.
    This is a 3.5SP5 issue where a fix Setting for SSL is set.
    so for 3.5SP5 Users at the moment the download of libs and update packages does not work.
    So if possible an update to current CODESYS Version will solve it too.

    BR
    Edwin

     
  • eschwellinger

    eschwellinger - 2015-12-10

    Hi,

    now it does work again even with CODESYS 3.5.SP5
    BR
    Edwin

     

Log in to post a comment.