v3.5 SP19 - Modbus TCP Devices - Channel Limit?

  • scoob

    scoob - 2023-05-04

    I have just updated a project from SP16 to SP19.

    I have added a new Modbus TCP Slave Device and started adding channels - I have added 10 and now it has greyed out the Add Channel button. Does anyone know if this is a bug, or a setting which needs changing?

    I opened another device which is already in the project, it has 81 channels already - but does have the button to add more greyed out?!

    Thank-you in advance!

  • kislov - 2023-05-05

    It will be fixed in CODESYS Modbus
    Plan to release: 23/05/23

    • diguananhai - 2023-05-26

      HI ,

      where i can download CODESYS Modbus

      • kislov - 2023-05-26

        Tools - CODESYS Installer - check Updates tab

  • scoob

    scoob - 2023-05-05

    Hi kislov, thank-you for the update, I have found a work-a-round for now as I upgraded to start using Git.

    I did try downgrading (using update, and showing old versions) one of the modbus devices so it is version - but it still had the 10 channel limit.

    As a work-a-round for now if it helps anyone else, it seems I can create the modbus device with all the needed channels in an old project from v3.15 SP16 for example, then copy and paste it into the new project, then use the update device to bring it up to the latest version (at least that is the latest version I have installed)

  • scoob

    scoob - 2023-05-05

    Hi kislov, not sure if it would make any difference, but I tried adding a new modbus device in v3.5 SP16 - it wanted to add the latest version - I proceeded to add channels, and it will allow me to add more than 10 channels. It seems like it is SP19 that is introducing the limit, rather than the modbus device specifically.

  • kislov - 2023-05-05

    This "limit" appeared as a bug along with the new (SP19 introduced) mechanism for processing "Paremeters lists" in Library Manager.

  • scoob

    scoob - 2023-05-09

    Thanks for clarifying kislov!

    I have just opened up an old project, in v3.5 SP16, the modbus definitions were missing (, so I "Downloaded the missing device description", now I get a build error saying:
    Max. number of Channels (10) exceeded ! - has the bug been introduced along with the release of SP19 but is backwards applicable as well for any downloads - older versions included?

  • kislov - 2023-05-10

    Please upload simple test project from V3.5 SP16 with this error.

  • eschwellinger

    eschwellinger - 2023-05-11

    think this will be solved with version.-
    sorry i was wrong with this..


    Last edit: eschwellinger 2023-08-28
  • scoob

    scoob - 2023-06-05

    Hi all, I have updated via Tools->Installer, but the Modbus Slave Device is not updated - so the Modbus Master and Modbus Slave are at v4.3.0.

    But when I then add a Slave to the Modbus Master Device - it will only allow 4.1.0 - which still has the 10 channel limit?

    Am I doing something wrong?


    Master Device:

    Slave Device:

    Add channel greyed out:



    Last edit: scoob 2023-06-05
  • fabian - 2023-08-28

    Hi all,
    Is there an update on this topic?
    Same problem here, I can not add more than 10 Modbus-Slave channels.
    Is there a workaround?

    Many thanks!

    Codesys 3.5.19 SP2, Modbus,
    Name: Modbus TCP Slave
    Hersteller: 3S - Smart Software Solutions GmbH
    Kategorien: Modbus TCP Slave
    Typ: 89
    ID: 0000 0005
    Bestellnummer: -
    Beschreibung: Ein Geraet, das als Slave fΓΌr einen Modbus TCP Master konfiguriert ist.
    Version Konfiguration

  • eschwellinger

    eschwellinger - 2023-08-28

    Guess you could just add two modbus slaves with the same ip, to enlarge the 10 channel limit.

  • laazik2 - 2023-09-05

    I am actually wondering as well if there are plans to fix it or not? As adding two modbus devices creates it's own problems with connection limits and other issues, which some slave devices have.

  • mozburg - 2024-01-18

    Has there been any progress on this issue? Currently running sp19 patch 5 with all packages updated but unable to add more channels...

  • jbarrio - 2024-01-22

    Also, this solution is not valid for the RTU, I imagine that this bug should be a high priority...

  • hagroth - 2024-02-02

    Today I was struggling with the same problem. in search for a solution i found this thread. Then i tried some things. It doesn't seem to be just a libraries' fault. In addition to 3.5.19, we also have a 3.5.18 version installed, the library versions of Modbus_TCP_Master and Modbus_TCP_Slave are the same, but more than 10 slave channels can be added in 3.5.18

  • rh-pk - 2024-02-14

    Hi, i found a solution for me. I had installed a 'old' version of CoDeSys (3.5.18 P5). I tried to add channels there, which works fine. I created a new project, added an Ethernet-Port, added a Modbus-Master and then I copied the ModBus-Slave from my working project to the new project. Now I could add more channels. I add the channels 10 and 11. Then I deleted (please make a backup before :-) the original ModBus-Slave in my working project and copied the extended Slave back to my working project. Surprisingly it is now possible to add new channels. Maybe this will help you.

  • vincentger - 2024-04-09

    Any resolution on this? I have currently 75 channels in my project that i brought up from SP18, which means i am 65 Channels above the new limitation?

  • rh-pk - 2024-04-10

    Hello Vincent, I don't have 75 channels but it works for me as described above without any problems. There is also a parameter MAX_MODBUS_CHANNELS in the library parameters for the IoDrvModbusTCP module. The default value there is 100. Perhaps you are reaching the limit there? The value can be adjusted accordingly. I assume that this value is not accepted in the input dialogue and therefore the 'fixed' limit value 10 is used.


Log in to post a comment.