Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Device User Logon and No device is responding.. Pi4b codesys 3.5 SP19 2 + (64-bit)

  • martinll - 2023-09-10


    Im slowly starting to loose it and i need som help!

    After a few night of reading up and testing iΒ΄m still stuck as a rock and you guys and girls are my last resort for this project.

    Basic facts;

    Win 11
    Codesys 3.5 SP19 2 + (64-bit)

    Raspberry pi 4 model b 2 gb
    Raspian release 11

    What keeps me up late at night;

    Username and Password when trying to connect to device and device only beeing connectable for a few seconds.

    Some of the things I have tried;

    Username and passord;
    Credientials from the raspberry
    Usernames and passwords that I sometimes use (this was a longshot i know, but i was running out of ideas and energy). :)

    Epand filesystem,
    activating i2c, spi, 1-wire

    I can start the gateway and start the runtime.
    I cant install the edgearm64, arm64 runtime package eventhough I guess i should, i get


    [ERROR] Error output: dpkg: error processing archive /tmp/codesysedge_edgearm64_4.8.0.0_arm64.deb (--install):
    [ERROR] Error output: package architecture (arm64) does not match system (armhf)
    [ERROR] Error output: Errors were encountered while processing:
    [ERROR] Error output: /tmp/codesysedge_edgearm64_4.8.0.0_arm64.deb


    as a respons.

    I have tried to Reset Origin Device - no change.
    I have tried to remove the



    but i could not find it and i was not sure if i should add it instead but i did not want to mess somthing up.

    I have tried to create a second gateway with the specific ip if the pi, that did not help.

    Could it be that iΒ΄m currently connected to the pi through WIFI?

    I can ping the pi and I can connect and control it through VNC.

    When i scan to select gateway target (scan edge gateway) i find 17-21 devices but can find the pi throug the mac adress.

    I started of trying to use the "CODESYS Control for Raspberry Pi SL" (I have a license sience earlier) as i read somewhere that this could be used on a Pi4 as well but now iΒ΄m trying with the MC SL, no changes, same problem.

    Right now - gateway version (edgearmHF, armhf), Runtime Package (raspberry, armhf).

    Any sugestions are very welcome! As mentioned above, theese are some of the things that i have tried/done - but i have been going at this for a while.



  • eschwellinger

    eschwellinger - 2023-09-11

    please use latest version and it is mandatory to have a user pi on your device.

  • martinll - 2023-09-11


    Thank you for your reply!

    What should be the version

    I have a user named pi on the pi, thats what iΒ΄m using as credientials to be able to for example update/install runtime. Or do i need another user?

    once agin, thank for the reply!


  • eschwellinger

    eschwellinger - 2023-09-11

    CODESYS runtime version for your Pi.
    ssh user should be pi. This is for RasperrPi Os 32 bit.
    If you are on RasperryPi OS 64Bit use Arm 64bit SL product as Runtime.


    Last edit: eschwellinger 2023-09-11

Log in to post a comment.