CODESYS OPC UA

2018-06-04
2018-06-06
  • ronald.de.jonge

    ronald.de.jonge - 2018-06-04

    According to the website CODESYS supports OPC UA profile „Micro Embedded Device Server“. I like to know if the CODESYS OPC UA server also supports client/server communication security according to the OPC UA specifications.

     
  • eschwellinger

    eschwellinger - 2018-06-04

    Hi,
    if you think on encrypted communiation between OPCUA Server and Client yes.
    But depends in which Version your plc is.
    You need to install the security agent from the CODESYS store.
    https://help.codesys.com/webapp/_cds_ru ... -ua-server

    BR
    Edwin

    IMG: generateCertificates.jpg

     
  • ronald.de.jonge

    ronald.de.jonge - 2018-06-06

    We are using CODESYS 3.5.X runtime toolkit for ARM-LINUX. What is the minimum runtime version that we need to support OPC-UA including encrypted communication between Server and Client?

     
  • eschwellinger

    eschwellinger - 2018-06-06

    Hi,
    I think this should be 3.5SP12 and you need the security agent from store to have it easy to use.
    BR
    Edwin

     

Log in to post a comment.