CODESYS Control for PFC100 SL, Error while installing package

kimao
2018-09-05
2018-09-25
  • kimao

    kimao - 2018-09-05

    Hello

    Trying to install the CODESYS Control for PFC100 SL i get error messages. Anyone know what could be the problem/solution?

    IMG: codesys error.jpg

     
  • eschwellinger

    eschwellinger - 2018-09-09

    Hi,
    never seen, which firmware is this,what happens if you install it by login by ssh and:
    ipkg install codesyscontrol_arm_pfc200_V3.5.13.x.ipk

    BR
    Edwin

     
  • kimao

    kimao - 2018-09-13

    Hello
    I am using this package: codesyscontrol_arm_pfc100_V3.5.12.40.ipk

    Using ssh I get the same error:

    root@PFC100-416D28:~ ipkg install codesyscontrol_arm_pfc100_V3.5.12.40.ipk
    ipkg: Couldnt kill old gunzip process aborting

    If I log into the web interface of the PLC I get the 3S interface and not the wago Interface, It seems like it might be installed.

    If I scan for PFC100 in the PFC100 phane in codesys I find it.
    If I scan for the device in my project i don't find it.
    If i try to start the Runtime using the start button in the PFC100 phane in codesys I get an error message..

    See attached photos.

    IMG: codesys start runtime.jpg

    IMG: codesys info.jpg

    IMG: codesys scan.jpg

    IMG: codesys scan pfc.jpg

     
  • eschwellinger

    eschwellinger - 2018-09-13

    Hi,
    Installation is ok,
    just add a Gateway with the IP of the PFC100. Switch to this new Gateway, then you will find the PFC100 by the scan.

    BR
    Edwin

    IMG: add.png

     
  • kimao

    kimao - 2018-09-21

    Hello, thank you for the reply.

    Adding a gateway with the IP of the PLC does not help. I get this error message.

    IMG: scan failed.jpg

     
  • eschwellinger

    eschwellinger - 2018-09-22

    Hi,
    could you Login by ssh (putty for example) and call
    top
    or
    cat /tmp/codesyscontrol.log
    to chek if the runtime is running?

    BR
    Edwin

     
  • kimao

    kimao - 2018-09-25

    Hello
    codesyscontrol.log is not found,

    IMG: top.jpg

     
  • eschwellinger

    eschwellinger - 2018-09-25

    Hi,
    your screenshot say you are using Firmware(09) Version,
    I would update to current Version ( request on Wago homepage for the new Firmware 11)
    Boot with it from micro sd and update your Firmware by WBM in the browser...

    BR
    Edwin

     

Log in to post a comment.