Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Gateway via AP & Router

  • mab8 - 2022-04-05

    Some problem with gateway configuration, PC codesys application localhost is connected with AP WIRELESS-LAN and another second router with wired LAN where controller works. Codesys gateway does not connect with it.
    No router roules apparently blokcs communication.
    Windows PC routes are enable to gateway of controller.
    Ping command from pc works, if I use a maintenance tool of controller it works properly.
    Codesys localhost and controller have different IP class, in differente LAN.
    Any idea how to makes routes in codesys gateway?

  • eschwellinger

    eschwellinger - 2022-04-06

    which controller type and which exact version are involved?

  • mab8 - 2022-04-07

    controller IFM, CR720S CodeSys V3.5.11.0 (32bit)

  • mab8 - 2022-04-08

    Problem solved, with last version of CSYS Gateway connection to controller works
    Thanks you!

  • e60newbie - 2022-10-23

    I have a similar problem with a TTC580.
    The TTC is connected by a router over a VPN where i made an iroute to the net of the TTC.
    By scanning the Net of the TTC I can't find the device. I use Codesys SP10 as recommanded by TTcontrol. I tried also with the 3.5.16.x edge Gateway without success.
    Any ideas? The Device don't has a default Gateway set on it (is not implemented). Don't know if can cause this the problem?

  • eschwellinger

    eschwellinger - 2022-10-23

    not scanning it..just type in the ip of the plc should work

  • e60newbie - 2022-11-08

    Hi Edwin,
    also with putting in the IP directly won´t work.
    The Device is Pingable, but Codesys can´t find and connect.
    I Attach my routing Table.
    Where the x.x.1.5 is the TTC,
    the x.x.255.0 is the VPN IPnet,
    the is the Wired WAN net.
    I tried a Connection with the Hercules Tool with Port 1217 (TCP + UDP), the Port are not locked and the Messages passes well in both directions.
    Are you shure that a Missing Default GW on the TTC won´t affect this problem?


Log in to post a comment.