CodeSys Control Win SysTray not starting

2021-01-07
2021-01-08
  • codesystart

    codesystart - 2021-01-07

    Hello,

    I was using CodeSys 3.5.14.20 until yesterday it worked fine.

    Today i tried to install 3.5.16.30 & the problem started.

    I am not able to start CodeSys softPLC.

    So i uninstalled all versions of CodeSys & deleted all installation folders related to codesys from installation directory.

    I again made a fresh installation of 3.5.14.20 but the issue is not resolved.

    I also tried to activate it from windows services but without any success. I get following error code in windows services. error 1075 - dependency service not found or marked for deletion. I have attached the screenshot of same.

    Could someone help me with this??

     
    👍
    1

    Last edit: codesystart 2021-01-07
  • codesystart

    codesystart - 2021-01-08

    When I tried to re – install 3.5.1.4.20, I got following error code…1722

    I have attached screenshot…

     
    👍
    1
  • codesystart

    codesystart - 2021-01-08

    Hello morberis

    Thanks for the reply.

    I was having problems since yesterday.

    I spent the whole day installing and uninstalling codesys.

    But finally at the end of the day it started working again.I am not sure though exactly what steps solved the problem.

    I think I reinstalled the codesys without uninstalling. Basically repair installation.

    The First time I did this it removed the above program. But since problem was not solved I did a repair installation again.

    This time the setup installed above program again.

    Before that I think I did a manual installation of codemeter also, which is a dependency service for above program/service.

    I am posting this if it helps somebody. Cheers😀😀

     
    👍
    1
    • Morberis

      Morberis - 2021-01-08

      That does not sound fun. I'm glad you got everything working again though and thank you for the follow-up post.

       
  • Morberis

    Morberis - 2021-01-08

    That seems to be a windows installation error message possibly relating to corrupted registry keys.

    First, because it seems really easy, try running the installation and uninstallation with your anti-virus disabled. I don't have high hopes for it but it's low hanging fruit.

    But looking up error 1722 I find this advice


    Error 1722 is a general error associated with the Windows Installer.

    Method 1: Check if the Installer Service is running. To do so, follow these steps.

    a. Click Start, Click Run and type “Services.msc” (without quotes) and press Enter.
    b. Double-click Windows Installer.
    c. Set the Startup type of Windows Installer to Manual.
    d. Click Start to start the service. Note down the error message if any. Click OK.

    Method 2: Reregister the Windows Installer. Follow these steps for the same.

    a. Quit all Windows programs.
    b. Click Start, All Programs, Accessories and click Run. Type “msiexec /unregister” (without quotes) in the Open box, and then click OK.
    c. Click Start, All Programs, Accessories and click Run. Type “msiexec /regserver” (without quotes) in the Open box, and then click OK. Restart your computer.


    Here is another windows support page with some info.

    Since it might be related to corrupt registry keys the advice at the end of this thread might help you.

     

    Last edit: Morberis 2021-01-08

Log in to post a comment.