Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Problems with Raspberry Pi - IoDrvGPIO library

correo0269
2024-04-05
2024-05-14
  • correo0269 - 2024-04-05

    I am trying to create a new proyect using the Raspberry Pi 4.11.0.0 package with Codesys 3.5 SP20, I am able to communicate with the Raspberry and start the runtime application but when I create a new proyect I have these errors. When opening the library manager of the proyect the library of the IoDrvGPIO is used so I dont really know whats happening.

     
    πŸ‘
    1
  • eschwellinger

    eschwellinger - 2024-04-05

    update device and update gpio devices by rightclick on the device tree

     
  • correo0269 - 2024-04-05

    i have already done that but it still has those errors

     
  • RasPi-User - 2024-04-06

    For me the same thing when opening the project. But the project is easily compiled!

     
  • correo0269 - 2024-04-06

    Yes, but I want to use 1-wire and I2C and I am not able to do it due to those errors

     
  • jernejs - 2024-05-14

    Hello, I have the same problem.
    Please for help.
    Thanks.

     
  • eschwellinger

    eschwellinger - 2024-05-14

    this is only a precompile error, will be solved but you ignore it works without any problem

     

Log in to post a comment.