Softmotion axis to CANopen Maxon IDX drive

  • spiessli - 2024-01-05


    I want to use Maxon IDX drives for some simple robotic applications. I have used Maxon's Epos for generating a DCF file to import in Codesys (attached). Then I can add the IDX motors under a CANopen manager in the device tree. Unfortunately, I cannot add a "softmotion axis" to the IDX motors. Now I am wondering, why? Without being able to attach a softmotion axis to the device in the device tree, the use of the motor is greatly reduced...


  • eschwellinger

    eschwellinger - 2024-01-06

    I would try to use the EDS file of the maxon drive.

  • spiessli - 2024-01-07

    Thanks for the advise, indeed, this was somewhat, what my intention was. I tried around again with EDSes and DCFs, anyway. It appears that the DCFs end up in a subfolder in the attach device dialog. Astonishingly, when attaching the DCF version I get a device in the device tree, where I can add a SoftMotion axis, whereas when I attach the device not in the subfolder, then I cannot. Further astonishingly, when looking in the CANopen parameters in supported profiles, "402" is listed in the case of the DCF variant, whereas in the EDS variant "0" is shown. Comparing EDS and DCF files I cannot guess, where the difference is coming from. I cannot tell either why I have always attached the EDS variant and apparantly never the DCF variant. As I am not in the lab right now, I cannot test if the connection actually is working.
    Thanks again,

  • eschwellinger

    eschwellinger - 2024-01-07

    can you add here the EDS file?

  • spiessli - 2024-01-08

    Just verified the behaviour. Still is the same. It should be attached here.

    But I also tried the DCF-file with the axis in the lab with the real drive: The MC_Power block never goes out of busy. Had not time to investigate further, though.


Log in to post a comment.