Build Error - Upgrading the SoftMotion

Motion
jonh
2020-08-05
2020-08-12
  • jonh

    jonh - 2020-08-05

    Hi,

    I am trying to convert a project from version 3.5.6 to 3.5.16.
    I'm getting the attached error.
    In project settings I've updated the SoftMotion version to 4.7.0.0 but still getting the same error.
    Should I update the soft motion virtual drivers devices? (all are version 4.0.0.0) if so, where can I find a newer xml file?

     
  • eschwellinger

    eschwellinger - 2020-08-05

    Hi,
    I would update the Softmotion via Package Manager in CODESYS.
    Set all to newest - and seems that the Ethercat Master need an update too.
    (rightlick in the device tree -> update device)

    Best Regards
    Edwin

     
  • jonh

    jonh - 2020-08-09

    Hi Edwin, Thank you.
    I made a progress with the Build, But now I am getting the attached message.
    The device that I intend to use has a 64 bit runtime system. How can I update these libraries? or is there a work around?

    Edited:
    I have also tried to update the SoftMotion via the package manager, I've uninstalled it first, I thought it would solve some issues, Now I want to install it but the package is gone and I cannot find where to download it. Can you also explain how to get it?

     

    Last edit: jonh 2020-08-11
    • Morberis

      Morberis - 2020-08-11

      If you push the 'Install' button on the top right it should let you select the softmotion package, you'll have to navigate to wherever it's been downloaded to or stored at. If you don't know or don't have it anymore you can download it at the below links. You don't need to pay for it, it follows the standard Codesys Demo rules.

      International Store Link
      North America Store Link

       
  • jonh

    jonh - 2020-08-12

    Thank you!

     

Log in to post a comment.