Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Nidec (CT) Unidrive won't enable

  • jmarshall9120 - 2023-07-08

    Trying to get my first drive online with Softmotion.

    It won't enable, it stays in the busy phase of the 'MC_Power' Function block. Despite this the state of the axis seems to be reading as 'Standstill' and the parameters all look good. To my knowledge, this means the drive should be enabling.

    Steps for setup:
    - Scanned for devices on my Ethercat Network
    - Copied device to project which the scan found (Unidrive_M700_RFC_S (Unidrive M700 RFC-S)).
    - Right clicked device in the device tree and added a "Softmotion CiA402Axis". Which the Nidec docs say the drive supports.
    - Added a Program POU called "TestServo_PRG" and added it to the "EtherCAT_Task" in the Task Configuration

    I'm using a visualization to control my MC_Power block. Flipping on the inputs causes the block to hang in the "Busy" state.

    However the axis' actual state is in "Standstill", and parameters being read into the axis object from the drive look like the drive is enabled.

    Here are all the parameters:

    Can anyone understand why this drive won't enable?


    Last edit: jmarshall9120 2023-07-08
  • eschwellinger

    eschwellinger - 2023-07-09

    you need to change the drive in the device tree to the existing driver for this drive - I would not use the generic DS402 if a driver is available. See screenshot.


    Last edit: eschwellinger 2023-07-09
  • jmarshall9120 - 2023-07-12

    @eschwellinger - Thank you for the response. I'm trying to implement your suggestion. Based on the driver you suggest I get a revision mismatch.

  • eschwellinger

    eschwellinger - 2023-07-13

    for a test disable under expertsettings the revision check
    - then contact the drive manufacturer (if your Soft Motion version is latest)

  • jmarshall9120 - 2023-07-15

    @eschwellinger - removing the revision check worked. Thanks!!!

  • jmarshall9120 - 2023-07-20

    @eschwellinger - After using your suggestions I've the axis working but I've noticed the MC_Power block still doesn't function right. The axis goes into standstill state and is usable, but the status output doesn't light up and the block stays busy? Any ideas why this might be? Else, if its a bug do you how best to report it?



Log in to post a comment.