• polygj

    polygj - 2018-01-08

    Can interface communication is all right in the terminal, but it is wrong in the codesys.
    I have configured the can interface in the way in the forum, but the problem couldn't be solved.
    I have no way to deal with the problem, please help !

    IMG: pic4.jpg

    IMG: pic5.jpg

    IMG: pic3.jpg

    IMG: pic2.jpg

    IMG: pic1.jpg

  • eschwellinger

    eschwellinger - 2018-01-09

    is this 3.5SP12 Version?
    Guess you need an entry in your /etc/CODESYSControl_User.cfg for example the following entry
    where the script is located (this is like it is the beaglebone black done) :



  • polygj

    polygj - 2018-01-09

    Thank you very much! The problem seems to have been solved! And I'll test it in detail later.

    IMG: pic1.jpg

  • Kalyani-K

    Kalyani-K - 2019-07-18

    Hi there!

    I am also trying to set up the same circuit as seen in the image attached by you.

    Can you please tell me the steps(commands) to be taken to be able to set up can1?

    I managed to set up can0 using the commands mentioned in the following link:

    I also changed the file pathway for the script as mentioned by Edwin.

    However, I am now blind to be able to set up can1, such that two MCPs can run on a single raspberry pi.

    It would be very helpful if you told me about what you did.

    PS: I am not from Linux background.

    Thanks again for your time!!

  • crazy-sonic82

    crazy-sonic82 - 2020-09-04

    Hello everybody,

    I wasn't sure if I should open a new thread or not. So I attached to this old one, sorry for that. I have a Raspberry 2 with PiCan v2 revB like the previous speakers. I have worked through all the steps and I can't get the bus running, see picture. I hope someone can help me.

    Many greetings


    Last edit: crazy-sonic82 2020-09-04
  • eschwellinger

    eschwellinger - 2020-09-05

    For me it looks like the can bus resistors are missing or no slave is connected or wrong baudrate...the driver seems to work if you get these messages.


    Last edit: eschwellinger 2020-09-05
  • crazy-sonic82

    crazy-sonic82 - 2020-09-06

    Hi Edwin,

    The Resistors are installed, an i have a Wago 750-338 with 8 inputs and 8 outputs connected.
    The configuration shoud be ok. The PiCAN works fine on System Level or with a Python script.

    I use CoDeSys 3.5 SP15 Patch4.



Log in to post a comment.