Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

ac_datalog causes runtime exception on RPi after a while

lingvo
2021-08-22
2021-09-01
  • lingvo

    lingvo - 2021-08-22

    Hi there.
    I'm using RPi 3 in my lab with Codesys licence (3.5.SP15) as a controller for a test stand. Sometimes this equipment runs 24/7 and it did it without any issues so far. Very good stability.

    But recently I wanted to add data logging capability to my system, so I have installed ac_datalog module through composer. I've created one datalog channel and added there my boolean variables (about 50 variables). My runtime runs at 2ms, but for datalogger high task I runs at 5ms.

    When I tried it first time it worked nice, the only problem was that Runtime crashed sometimes at start (probably it tried to write all vars into same cycle, and they change a lot at start), so I have reduced dataloghightask from 5 to 10ms through generator. With this cycle rate runtime started to work reliably.

    But here is a big problem - now my system runs only for a few hours or up to one day and then crashes with exception. Attached is a screenshot of exception and log from device. It looks like there was a CRC error in datalog. With my number of vars the csv file grows about 4MB per day - at the moment of crash the csv file was about 3.8MB and as I read it - it is OK.

    Did this cause a crash? Why? Any hints how to avoid this problem?

    Would be very thankful for any help. I liked datalog feature, so don't want to switch it off and do something own.

     

    Last edit: lingvo 2021-08-22
  • lingvo

    lingvo - 2021-08-27

    Any suggestions anyone?

    I had to remove ac_datalog from the project as at this stage it is unsuitable for prolonged use and crashes the system after few tens of hours.

     
  • eschwellinger

    eschwellinger - 2021-09-01

    not sure if exesive writng on SD card is a good idea - as first step I would write to a network drive if possible/available - usb harddisk is maybe an option too.
    if this problem then still persists - should be investigated / debugged.

     

Log in to post a comment.