Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

PFC100 Licensing fails

  • aleoin - 2022-02-23

    Hello all,

    I hope you are well.

    We are having problems with licensing PFC100 controller.
    We are using WAGO PFC100 (750-8101) in one of our machines and for some reason it seems that we are not able to activate license on this controller.

    We installed CODESYS Control for PFC100 SL package to our controller and downloaded the application, everything went well.

    We used Codesys license manager to activate the license and the activation procedure with tickedID succeeded.

    As you might see from the image above, it seems that the license is OK.

    Now, everything works well until 120min of runtime is reached and the runtime stops. In the PLC’s log, we have one warning: “no runtime license – running in demo mode(~120 minutes)”.

    So, it seems that the license is not actually activated on the device.
    We have now activated a license and tried to reactivate it (and even purchased another license) but after 120min the runtime stops.
    Every time the PLC's log shows that same: “no runtime license – running in demo mode(~120 minutes)".

    Any help with the issue is appreciated!


  • eschwellinger

    eschwellinger - 2022-02-23

    which runtime version is this?

  • aleoin - 2022-02-23

    Hi Edwin,

    We are using CODESYS Control for PFC100 SL version

    I found quite similar issue with raspberry pi, in thread:

    I haven't tested the solution yet, but it might do the trick, we are running the system from SD card also. In our case the SD image was completely blank before we downloaded the application and tried to do the licensing. It might still be, that the soft container in the SD card is somehow corrupted or faulty?!

    Thanks, I'll keep you updated!


  • eschwellinger

    eschwellinger - 2022-02-23

    Hello Aleksi,
    ok version, you need to check:
    If you plug this SD card in another PFC ( which has another hw-serial number) you'll get a second empty softcontainer.
    This could lead to an unlicensed PFC (it could only handle one container)

    The solution is:
    To delete the
    /var/opt/codesys/cmactlicense directory and content of it - and relicense you PFC with the correct PFC Update license file which does fit to the PFC ( which you find under : c:\ProgramData\CODESYS\Licenses\XXXXX-XXXXX-XXXXX-XXXXX-XXXXX\0007324B9049.WibuCmRau

    XXXXX-XXXXX-XXXXX-XXXXX-XXXXX -> your license ticketnumber
    0007324B9049 -> MAC ID of your PFC

    keep in mind version < it is
    from runtime version it is:


  • aleoin - 2022-02-24

    Hi Edwin,

    The issue was indeed related to SD cards soft container.

    As a solution we deleted all the files from PLC's cmact_license folder and rebooted the system. After reboot, we reactivated the license with previously used ticketID (The same we used to do the initial licensing). After the reactivation the problem seems to be solved and PLC log stated: “runtime licensed”.

    Thanks Edwin for your assistance!


  • cavein - 2024-03-19

    Hi, i have a similar problem. im using pfc200
    There are two softcontainer and only one with license in it. every 1-2 hrs it will auto logoff. i tried the steps above but i dont find the /var/opt/codesys/.cmact_licenses

    i need help please.

  • eschwellinger

    eschwellinger - 2024-03-19

    possible to use a newer version?
    maybe it is /var/opt/codesys/cmact_license in your version


Log in to post a comment.