Modbus TCP error > Slave does not support this register offset

Runtime
2020-08-31
2020-09-05
  • manueldiasm

    manueldiasm - 2020-08-31

    I am trying to communicate by Modbus TCP being Codesys the master to a Micro 820 from Rockwell automation but i get the error " Slave does not support this register offset ". Any help to solve this issue ?

    Regards,

    MDias

     
  • i-campbell

    i-campbell - 2020-08-31

    What does your Modbus Mapping look like in CCW?
    What does your Modbus channel configuration look like in CODESYS?

     
  • manueldiasm

    manueldiasm - 2020-09-01

    The Modbus Tool that communicates fine with CCW does not communicate with Codesys as a Master . Any tip ?

    When i use the same tool being Codesys the slave the communication is fine. Help ?

     
  • kislov

    kislov - 2020-09-02

    As I see in CODESYS you use Modbus function 03 but in Modbus tool you use function 01 (because variable type: coils). I think you should try function 01 in CODESYS too.

     
  • manueldiasm

    manueldiasm - 2020-09-02

    Thanks, but i have already tried all type of Modbus Function with Codesys and even i tried to use a PLC from Siemens insetad of Micro820 but no success so far.

    Codesys as a slave seems to work fine but not as a master. 😟

    I am using a Pi 3+.

     
    • aliazzz

      aliazzz - 2020-09-02

      Why don't you try to read/write into your localhost pi using the CODESYS master first? That way you can test it without external tools and get a better feeling for it.

       
  • manueldiasm

    manueldiasm - 2020-09-05

    It´s working well with CCW now. Thank you for your wise advice.

     

Log in to post a comment.