Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Problem to connect with Raspberry pi2

sestodk
2017-06-03
16 hours ago
  • sestodk

    sestodk - 2017-06-03

    Hi guys,
    i have a problem with connection between codesys and raspberry. I'm using codesys with control for raspberry 3.5.10.20, and in rasberry there is RASPBIAN JESSIE WITH PIXEL Version:April 2017 Release date:2017-04-10 Kernel version:4.4. I'm using a demo version of raspberry license. If i try to do the raspberry update by menu tool, the raspberry will update without problem. When i try to download the project or to connect in the application page with enter the ip iddress of raspberry, doesn't work and poput appeare "No device responds to the scan request". It worked until a few days ago. I don't know what has changed. I tried to reinstall jessie on raspberry without success. The ssl connection with putty and ping to raspberry works.
    this is the codesyslog

    Linux version 4.4.50-v7+ (dc4@dc4-XPS13-9333) (gcc version 4.9.3 (crosstool-NG c rosstool-ng-1.22.0-88-g8460611) ) #970 SMP Mon Feb 20 19:18:29 GMT 2017

    * CoDeSysControl DEMO VERSION - runs 2 hours*

    machine: armv7l
    timer resolution: 1nsec

    =======================================================================
    1496251480: Cmp=CM, Class=1, Error=0, Info=4, pszInfo= CODESYS Control V3
    1496251480: Cmp=CM, Class=1, Error=0, Info=5, pszInfo= Copyright (c) 3S - Smart Software Solutions GmbH
    1496251480: Cmp=CM, Class=1, Error=0, Info=6, pszInfo= <version>3.5.10.20 <builddate>Mar 13 2017</builddate></version>

    Can you help me to solve the problem?
    thank you

     
  • teichhei

    teichhei - 2017-06-03

    What happens when you just enter the correct IP address in the field and hit enter, without scanning for the pi? That usually works for me.

    Sent from my SM-G935F using Tapatalk

     
  • sestodk

    sestodk - 2017-06-03

    Doesn't found anything. Is crazy, 3 days ago it works..also in the raspberry update the scan Doesn't found raspberry, but if i enter the ip address manually the update works. But in the application label where are gateway and device, doesn't found the rpi.

     
  • teichhei

    teichhei - 2017-06-04

    When I had that problem Codesys had an issue with another codesys version's gateway (Wago eCockpit). Is the gateway service running?

    Sent from my SM-G935F using Tapatalk

     
  • eschwellinger

    eschwellinger - 2017-06-04

    Hi,

    I would recommend to check by ssh:
    cat /tmp/codesyscontrol.log
    If this is caused by an corrupt bootapplication / application crash in your applicaion
    you could delete this by
    sudo -scd /root/PlcLogic/Applicationrm Application.*

    then restart the plc by
    /etc/init.c/codesyscontrol stop/etc/init.c/codesyscontrol start

    this should solve it.
    Bye the way you could use the CODESYS Pi as Gateway:
    Add new GATEWAY in CODESYS with the IP Adress of your Pi.
    Switch to this new added Gateway and scan via this Pi Gateway, this works always, (and download is faster than just use the IPAdress on the right side of the communication dialog)

    BR
    Edwin

     
  • rbulha

    rbulha - 2021-09-02

    Hi,

    The thread is old, but I'm getting the same problem with my raspberry pi model B3. It was working fine yesterday but today I cant get connected. I've already did a full "remove" and "install" the runtime package, try using SSH login based, tryed to use the raspberry pi as Gateway, but I cant get connected.

    Strange thing is the Tool->Update Raspberry Pi panel connect and work fine, my raspberry show into the "Scan" list. But from the device panel I cant get connected. It prompet the login dialog but then:

    Any help?

    Just attached the log from: cat /tmp/codesyscontrol.log

    Regards,
    RogΓ©rio

     

    Last edit: rbulha 2021-09-02

Log in to post a comment.