Error when installing Raspberry Pi library

Runtime
2020-03-21
2020-03-21
  • dilophosaurus

    dilophosaurus - 2020-03-21

    Hello all,

    I'm a student Mechanical Engineering and I'm trying to set up an easy circuit using the SFC's of CodeSYS on a Raspberry Pi as a way to gain extra credit. However, when trying to install the library for the Raspberry Pi Controller, I always get the error that the file is not a ZIP file and this causes error when trying to start the SFC project. I have no idea what causes this error and I was wondering if any of you knew.

    Regards,
    Rick

     
  • eschwellinger

    eschwellinger - 2020-03-21

    Hi Rick,
    At the moment no idea what the reason is....could you try to install current Pi package by clicking on the shopping cart icon in CODESYS?
    Install it that way in the CODESYS developmentsystem.
    BR Edwin

     

    Last edit: eschwellinger 2020-03-21
  • dilophosaurus

    dilophosaurus - 2020-03-21

    Hi Edwin,

    Sadly this does not solve the issue... Could it be that because I'm using an older version of CODESYS, patch 3.5.10.70, that the library won't work? My college told us to install this patch to prevent "compatibility problems".

    Regards,
    Rick

     
  • eschwellinger

    eschwellinger - 2020-03-21

    Hi Rick,

    Yes, any reason not to update to current CODESYS Version?
    Sure the plc runtime in Pi need to be updated too
    BR
    Edwin

     

    Last edit: eschwellinger 2020-03-21

Log in to post a comment.