Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

newbie at codesys and raspberry pi

Runtime
Anonymous
2015-02-12
2015-02-13
  • Anonymous - 2015-02-12

    Originally created by: on4bhm

    Hi,
    I'm trying the demo examples of the raspberry pi. but non seem to work.
    i'm using 2.0.1.0 together with 3.5sp6

    when i open sample i get the message: one or more library references in this project failed to load.
    please take a look in the messages view for further details

    than i get project environment dialog:
    current compiler version in project 3.5.5.20
    recommended, newest version 3.5.6.0
    if i choose the action to update 3.5.6.0

    i system does something (not clear what)

    if i scan for raspberry pi, the device is found
    when i login, it comiles
    but i get 501 errors....

    What can i do?

     
  • fixstuff555

    fixstuff555 - 2015-02-13

    I'm guessing, the first thing they will probably want you to do is make a project archive of your project, so that they can see if something is messed up.

    File --> Project Archive --> Save --> then click save on the bottom of the next window.

     
  • eschwellinger

    eschwellinger - 2015-02-13

    Hi,

    in that case ... no, you only need to download the missing libraries by the LicenseManager.
    Maybe you should switch under Tools-Options-Features- Professional then you see all libraries in the LibraryManaager
    In 3.5SP6 you could download missing libraires and devices (to download devices is a new feature in 3.5SP6)

    BR
    Edwin

     
  • Anonymous - 2015-02-13

    Originally created by: on4bhm

    I can install libraries in the library repository.
    But where can i download them?

     
  • eschwellinger

    eschwellinger - 2015-02-13

    Hi,

    see screenshot --- if there are libraries with a '!' these are the one you are missing
    don't Forget o Switch to "professional" under the Tools-Options-Feature sets

    BR
    Edwin

    IMG: DownloadMissingLibs.jpg

     
  • Anonymous - 2015-02-13

    Originally created by: on4bhm

    ok, i got it....

    i'm having trouble with activating my license...
    is the license server up and running?

    but first i need to get my rapberry pi back up... at least de codesys runtime.... i can't find it anymore on the network.

    i did a upgrade of the raspberry pi last night. it must have broken something....

    can i start the runtime manually?

     
  • eschwellinger

    eschwellinger - 2015-02-13

    Hi,

    1. currently there is a problem on the license server / actvation is not possible
      2 manually start the runtime:
      first do a stop (if license time expired on a demo Pi)
      you need to:
      sudo /etc/init.d/codesyscontrol stop
      then
      sudo /etc/init.d/codesyscontrol stop

    BR
    Edwin

    PS: IF you are updating wheezy / and the kernel by rpi-update you have then 3.18 kernel which have some new features
    for example device tree support, which makes some changes in the /boot/config.txt necesarry,
    we will try to take all this changes into account with the new 3.5SP6 release next week.

    For those who can't wait with the new kernel and CODESYS Runtime:
    please add to /boot/config.txt

    dtparam=i2c_arm=on
    dtparam=spi=on
    dtoverlay=w1-gpio-pullup,pullup=1

    to have I2C / SPI and 1Wire with the new kernel and CODESYS Runtime

     
  • Anonymous - 2015-02-13

    Originally created by: on4bhm

    What must i do to make the raspberry pi demo's visible via hdmi output?

    I only see consoles.... no graphic view...

    kind regards

     
  • eschwellinger

    eschwellinger - 2015-02-13

    Hi,
    usuallly you execute http://PiIPAddress:8080/webvisu.htm
    on your windows pc. (Webvisu)

    If you want to see the webvisu on the PI:

    you need to install chrominum:

    sudo apt-get update && apt-get upgrade -y
    sudo apt-get install chromium x11-xserver-utils unclutter

    startx

    start then chromium and goto http://localhost:8080/webvisu.htm

    BR
    Edwin

     
  • Anonymous - 2015-02-13

    Originally created by: on4bhm

    so i can not use it as an application who makes the graphics on my screen.
    I Always have to use a browser?

    and what if my PLC has a connected screen?

    can't i visualize the graphic screens without browser?

     
  • eschwellinger

    eschwellinger - 2015-02-13

    Hi,
    Raspberry Pi does only support Webvisualisation not TargetVisu,
    you could execute chromium in fullscreen kiosk mode... if needed.

    How to do this?
    We need to prevent screen from going blank and disable screen saver.
    – edit /etc/xdg/lxsession/LXDE/autostart and comment # screen saver line and add those lines:

    @xset s off
    @xset -dpms
    @xset s noblank
    @chromium --kiosk --incognito http://some.web.bla.blub

    BR
    Edwin

     
  • Anonymous - 2015-02-13

    Originally created by: on4bhm

    can't i make HMI visualization?

    i'm investigating codesys if it is a solution for us:
    We are building our own PLC with a connected touch screen on LVDS.

    The screen MUST visualize the application !!

    We are planning on using an efus board from f&s
    and want to connect touch screen via LVDS.

    Are you saying that we are obligated to use a webbrowser?

     
  • eschwellinger

    eschwellinger - 2015-02-13

    Hi,

    if you build your own plc based on CODESYS based on an Linux System,
    you could install QT on your system (Linux) and then you need to have the targetvisu feature.
    Then you have visualisation on your local screen connected to your plc.

    BR
    Edwin

     
  • Anonymous - 2015-02-13

    Originally created by: on4bhm

    can't i install QT on my raspberry pi?

    What about odroid hardware family?
    w www.hardkernel.com w

    can i use that platform for codesys?

     
  • Anonymous - 2015-02-13

    Originally created by: on4bhm

    I installed qt4 now on the raspberry

    still don't see my visualization...

    do i have to do something extra?

     
  • eschwellinger

    eschwellinger - 2015-02-13

    Hi,
    come on.. I have written on a regular plc maybe Linux based, not on
    the teaching platform Raspberry Pi.
    On the Pi only webvisu is posiible.

    BR
    Edwin

     

Log in to post a comment.