Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Failed to insert library - CodeSys & Raspberry Pi issues

brendonm
2022-07-10
2022-07-13
  • brendonm

    brendonm - 2022-07-10

    I'm trying to setup a 1 wire temperature sensor and I'm running into an error with a library that fails into be inserted even though I've got the library added to the manager.

    a couple of pictures of my setup are attached.

    the couple of video's I've followed all show everything working right from the get go, but not in my setup.

    I can't seem to find any fixes for the error's that I'm getting.

     
  • i-campbell

    i-campbell - 2022-07-10

    my guess - right click the DS18B20 in the device tree, and select Update Device...

    the device description seems to be calling for an older version of the library to the one you have manually added

     
  • brendonm

    brendonm - 2022-07-11

    updating the device didn't change anything. i didn't manually add a library, it was the library that was available from the repository.

     
  • shan

    shan - 2022-07-11

    Try with deleting(right click on library) 1 wire temperature library in the library manager list which is shown with Blue label "i" and press "Add library" go to advanced tab and add the same library. This will make that library mismatch version and proper availability in the system.

     
  • brendonm

    brendonm - 2022-07-12

    There is no advanced tab while adding a library. When i expand the ds18b20, i would i assume i should see the ds18b20 listed in the library section?
    I've upgraded my version to 4.5, and tried the update device and rebuild the code but the errors continue.

     
  • shan

    shan - 2022-07-12

    Open your project and under the "Application" there is "Library Manager". double click on it open and press "Add Library"

     
  • brendonm

    brendonm - 2022-07-13

    @ shan, look at my picture #3, same steps as you indicated but there is no advanced tab.

    @ eschwellinger, your program worked. i'm not sure what the difference was between mine and yours.
    i did have to change up the device from raspberry pi MC SL to just raspberry pi SL as it was not compatible with my PI. i'm using a PI 3B. What is the difference between MC SL & SL.
    i also deleted one of the ds18b20 sensors, as i'm only using one.
    i had an issue where the ds18b20 stop running after an initial scan, but a simple PI reboot fixed it.
    time to get a licence now, so that i don't have to worry about the 2hr run time.

     

Log in to post a comment.