Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Attempt to upgrade a pi 3 from a working V3.5.11 to V3.5.15 fails

ctgarvey
2019-10-06
2021-07-13
  • ctgarvey

    ctgarvey - 2019-10-06

    I did not turn this pi on for 2 years, but it worked fine on v3.5 sp 11. Tried to upgrade to V3.5 SP15 Patch 1 64 bit. I can see there have been a few changes...

    Is there a problem with the 64 bit version and raspberry pi 3?

    There is now a different licensing process... So i bought a new license.
    There is now new security, authentication, user functionality. I am now on SP15. Is there any way i con confirm all this stuff is disabled?
    I cannot login to the pi with the defaults that i never changed: pi / raspberry. I can terminal log in via putty to the Pi just fine (not via codesys)
    I try to reset the origin device - but keep getting the message ' gateway not configured properly' even if CoDeSys appears to upgrade the Pi runtime successfully.

    Any tips most appreciated. Is there a new getting started guide for pi that is up to date with the latest changes?

    BR
    C

    IMG: CannotAccessCoDeSysonRaspberryPiAnymore.png

     
  • eschwellinger

    eschwellinger - 2019-10-06

    Hi,
    the license is the same.

    Seems that accidentally is activated the UserManagement.

    l viewtopic.php?f=11&t=10027#p25397 l

    The difference meanwhile there a two versions available
    1. Raspberry PI SL ( same like before)
    2. Raspberry PI SL Multicore ( possible to distribute the tasks to the avilable cores - this need another license, yes)
    Check if the online installed device is the same like in the project.

    BR
    Edwin

    IMG: onlinedevice_mc.png

    IMG: ProjectPLC.png

     
    • tyler-teh

      tyler-teh - 2021-07-13

      Hi
      I can see the device i want in this select device page, but when i click on the device and press ok, codesys will prompt me to enter username and password (although i has already press the "Reset Origin Device") and then when i enter my username and password, error "No device respond to scan request will pop out. i duno what else i can do to solve this.

       
  • ctgarvey

    ctgarvey - 2019-10-06

    I cant actually get online to the runtime, as i keep getting prompt for device user login.I cannot reset origin device, because i keep getting 'Gateway not configured properly'.
    I am still using debian version Jessie on the Raspberry pi. Could that be an issue.

    Is there any way to totally start again with codesys install on the pi, without having to re image debian onto the raspberry pi sd card?

    the update of pi appears to work with the messages in the screengrab

    IMG: Untitled.png

     
  • ctgarvey

    ctgarvey - 2019-12-01

    Edwin,
    any chance you can have a look at the following screengrabs of latest Codesys runtime on Pi SL and tell my if anything looks wrong ? Still cant get raspberry pi V3.5 runtime engine to work

    library manager

    I bought the Codesys control for raspberry pi SL - but it doesnt appear in this device repo. Should it appear here?

    Does the package manager look correct? . This used to work and now it doesnt and i dont know what success looks like. i.e what packages or libraries should be present here. Is there anything wrong with this list. I cant get basic pi functionality to work, never mind piface digital or weather sensor expansion boards.

    I can get sysinfo easily, and a runtime is running on the pi. However there is a bad error message saying reinstall is required. But I have done numerous reinstalls.
    Should i just delete all codesys files from the pi and start again?

    [attachment=0]pionline.png[/attachment

    Thanks for you help
    Cormac

    IMG: librarymaanger2.png

    IMG: devicerepo.png

    IMG: packagemaanger2.png

    IMG: sysinfo.png

    IMG: pionline.png

    IMG: CannotAccessCoDeSysonRaspberryPiAnymore.png

     
  • eschwellinger

    eschwellinger - 2019-12-02

    Hi Cormac,

    on the device repository you could select the Raspberry PI under the softmotion plc's.
    In general the following steps on a full update are the following:
    1. Update CODESYS development System
    2. Install Raspberry PI via Store shopping card icon in CODESYS ( to have the update checks for the package)
    3. Deploy the new runtime with the Update command
    4. Open project selcect if you asked to use newest compiler and visu profile
    5. then Update your existing projects by -> Update devive on the plc in the device tree and update GPIO's by rightclick update device
    If you have ethercat/profinet/modbus/eip in your project -> update them in the device tree by update device too.
    Doing this - you have all in newest version now.

    If you see this login window with credentials - ( i asume you do not have added them - otherwise you would know them) just use the defaults
    Administrator
    Administrator
    if needed - a reset original on the device ( do this command on right click in the device tree ) will clean up all files which are downloaded by CODESYS and even the Usermanagement will be reseted by this if accidentally activated.

    Hope this helps.
    BR
    Edwin

    PS: sure the license will stay on the device if you update to a new version.
    If a new sd card installation is needed you could activate the license by the license update file
    (which you could download from your licensed PI by CODESYS file browser -CMLicenseNew.WibuCmRaU)
    - newer COEDSYS versions generate a copy of this file on (xxxxx is your ticketnumber of the license):
    c:\ProgramData\CODESYS\Licenses\XXXXX-XXXXX-XXXX-XXXXX-XXXXX\serialno_of_your_runtime.WibuCmRaU
    Sure this doe only work on the same/correct PI.

     

Log in to post a comment.