Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Beckhoff

Runtime
stricky
2018-06-25
2018-06-29
  • stricky

    stricky - 2018-06-25

    Moinsen,

    quäle mich nun schon ne Weile ein paar beckhoff komponenten an nem Raspi zu hängen ...

    Die gleiche Config lauf auf nem Twincat 3 sofort und ohne Probleme

    EK1100 X1 Raspi ( oder halt Twincat zum testen )
    EK1100 X2 BK1120 und paar EAs
    EK1100 2 Klemme El6751 und daran einen BK5120

    Die Config im Codesys ist richtig ( denke ich jedenfalls ) ... könnte es was mit den Firmwareständen zu tun haben ... haben 06 aus BJ12 ( EK1100 )

    Kann ich die updaten ? Kann leider die .efw nirgends finden ... kann ich die nur vom Beckhoff Support bekommen ?

    Grüße
    Christian

     
  • eschwellinger

    eschwellinger - 2018-06-25

    Hi,

    du musst für den CANopen Koppler ne Konfig erstellen wie im Screenshot
    Für BK1120 muss man zwingend die MDP Varibante der ESI files verwenden.

    Grüße
    Edwin

    IMG: EL6751.jpg

     
  • stricky

    stricky - 2018-06-25

    das habe ich schon so gemacht ... habe mir das auch schon alles durchgelesen

    irgendwas ist da megafaul ... die mdp für den bk1120 hatte ich auch drin

    die el6751 will einfach nicht in op ... bleibt in pre-op hängen

    IMG: shot3.png

     
  • eschwellinger

    eschwellinger - 2018-06-25

    bitte ins Log schauen der SPS da muss stehen warum der nicht operational geht...

    Grüße
    Edwin

     
  • stricky

    stricky - 2018-06-26

    leider geht es immer noch nicht ... habe keine Ahnung mehr woran es liegen könnte

    auf jeden fall gibt es ein problem beim setzen der busparameter ( shot 15 )

    alles andere geht nur die 6751 nicht oder besser gesagt beide

    hat noch jemand ne idee ?

    grüße
    christian

    IMG: shot16.png

    IMG: shot15.png

    IMG: shot14.png

    IMG: shot13.png

    IMG: shot12.png

    IMG: shot11.png

     
  • eschwellinger

    eschwellinger - 2018-06-26

    Hi,
    kannst du denn die Konfiguration scannen?
    Findet der Master da alle Gerät oder passen da welche nicht von der Revision Typen?
    (rechclick auf dem Master und die Slaves scannen)

    Grüße
    Edwin

     
  • stricky

    stricky - 2018-06-26

    der bk1120 passte erst nicht .. da habe ich die revision in der xml angepasst ...das funkt jetzt

    bei der el6751 passen die revisionen auch

    scannen ethercat geht auch ...

    scannen vom can geht nicht ... da hängt sich codesys auf und lässt sich nicht mehr bedienen ... geht nur mit prozess beenden

    IMG: shot17.png

     
  • stricky

    stricky - 2018-06-27

    moin,

    keiner ne idee ? wie gesagt, im twincat 3 geht es sofort ... teile sollten somit ok sein

    es sieht ja so aus, als wenn die busparamter per sdo nicht zur 6751 geschrieben werden können ... woran könnte das liegen ? evtl passwort ?

    karten sind aus 2008 ... also schon was älter ? ist das evtl. das problem ?

    grüße
    christian

     
  • stricky

    stricky - 2018-06-27

    ich nochmal .... die EL6731 ( profibus ) geht auch nicht ...

    der bk1250 der dahinter hängt und die KL daran funktionieren

    die EL6731 wird ganz normal gefunden und ist grün nach der suche ... sobald ich daran dann einen PB master mache ( aktualisiere ) ist feierabend ...
    State geht auf Pre OP und geht nicht mehr in safeOP und dann in OP

    so hat die EL6731 das gleiche verhalten wie die 6751 ... bei funktionieren im twincat einwandfrei

    können das irgendwelche library geschichten sein ? habe jetzt 3.5.12.40 installiert und raspi package 3.5.12.30

    lizenz habe ich ebend auch mal installiert

    hilft alle nix ... jemand noch ne idee ?

    Danke und Grüße
    Christian

     
  • stricky

    stricky - 2018-06-27

    ok ... gerade gesehen ... also die el6731 kann ohne treiber ja nicht funktionieren

     
  • stricky

    stricky - 2018-06-29

    so ... kann geschlossen werden ... es war die firmware ... jetzt gehts

     

Log in to post a comment.