Problem with Codesys control for Raspberry

  • epinikion

    epinikion - 2021-04-01

    Hi all,

    I'm having problems with the Raspberry package for Codesys. I installed the latest versions of both codesys and the package. After installing it, the "update raspberry pi" button doesn't appear on the Tools menu. I got it to appear going to customize, but when I click on it I get the error "Could not find a part of the path 'c:\users\XXX\Codesys control for Raspberry Pi\Delivery'

    The folder is there, but after 'Control for Raspberry Pi' the next folder is named after the last version. And inside of it there is no delivery folder.

    Other problem is when I load an example from there. The devices seem missing, but if I add them myself on my project they are there. It is as if there were two versions conflicting or something, but I only see one installed.

    Best Regards



    Last edit: epinikion 2021-04-01
  • eschwellinger

    eschwellinger - 2021-04-02

    these problems are caused by user rights.
    The installation of CODESYS packages need admin rights ( a user which have it)
    but it is not: Starting CODESYS as administrator. (because then the package will be installed in the c:\Users\Administrator directory instead of c:\Users\YourWindowsUser
    From my expirience it is always this.
    Best Regards


    Last edit: eschwellinger 2021-04-02
    • epinikion

      epinikion - 2021-04-02

      Thanks for replying.

      I tried it on my company Laptop, so yeah it might be that. They gave me an admin account for installing stuff and it always worked with codesys packages, but yeah maybe this account has some limits too.


Log in to post a comment.