Unresolved Reference: "CODEMGETCONTENTBYFIRMCODE2"

francke
2018-10-29
2020-09-23
  • francke

    francke - 2018-10-29

    Hi,

    I'm using a Codesys RTE V3.5.9.40 for as my controller and when I am trying to download a program from my local PC I receive the error following error:

    When I open the PLC configuration for diagnostics, the logger shows up the following message:

    I have checked that all versions are compatible in the Development environment and the Soft-PLC as well as the libraries versions, but still this error shows up. Any ideas?

    Thanks,
    Alan.

    IMG: Unresolved Ref. Error 2.PNG

    IMG: Unresolved Ref. Error.PNG

     
  • eschwellinger

    eschwellinger - 2018-10-30

    Hi,
    seems that the codemeter component is missing in the CODESYSControl.cfg of your Control RTE.

    BR
    Edwin

     
  • francke

    francke - 2018-10-30

    Thanks alot for your reply. I realized that when I installed the RTE on my machine, I removed the CodeMeter feature at install, I wasn't sure exactly if I would need it.

    I reinstalled Codesys and made sure to leave this feature on, an it solved the issue.

    Regards,
    Alan.

    IMG: CodeMeter.PNG

     
  • jrenner

    jrenner - 2019-05-24

    I am using E!cockpit from wago and it uses Codesys 3.5. I have the same error. How do I fix that with E!cockpit?

     
    • codesysuser

      codesysuser - 2020-09-23

      Hello, Did you find solution for this problem. I have the same issue
      Best regards
      Anton

       
  • eschwellinger

    eschwellinger - 2019-05-27

    Hi,
    please ask the Wago support for advice.

    BR
    Edwin

     

Log in to post a comment.