Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Unable to download the Codesys program to Raspberry Pi 4

suyash
2022-07-04
2022-07-05
  • suyash

    suyash - 2022-07-04

    Hello!

    I am facing an issue downloading program to my Raspberry Pi 4.

    Background
    I was earlier working on a Raspberry Pi 3 (for Codesys) and it was working flawlessly. Now I am have installed the Codesys control for Raspberry Pi on my RPi4.
    The dhcp is enabled on it and i2c and spi interfaces have also been enabled.

    I was able to successfully install Codesys Control 3.5.15.10 on my new RPi 4. However when I try to scan my device, it doesn't get scanned. Later when I disable application under Update Raspberry Pi section, the device gets scanned. After connecting with the device, I start the Runtime and then try to download my PLC program. The program downloading suddenly gets interrupted typically at 30% and I get a pop up - No connection to your device. I get this error despite my connection on VNC being completely fine. I am not able to find out the cause of this issue. Pls help!!

    Best Regards,
    Suyash Thatte

     

    Last edit: suyash 2022-07-04
  • eschwellinger

    eschwellinger - 2022-07-04

    I think you need at least update the runtime side, to current version.( if you are runnung Bullseye)

     
    • suyash

      suyash - 2022-07-05

      Do I need to update the OS or the Codesys runtime ?
      Yes I am currently using Bullseye..

       

      Last edit: suyash 2022-07-05

Log in to post a comment.