Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Scan network does not find industrial PC running the CODESYS Control for Linux runtime

muegggge
2022-01-06
2022-01-07
  • muegggge

    muegggge - 2022-01-06

    Hello,

    I have got a runtime running on an inudustrial pc running debian. Installing the package "CODESYS Control for Linux SL" worked and I can start the runtime via the CODESYS Development Environment. I checked this by opening the system information under Tools->Updgrade Linux.

    Now I want to establish a connection to load an application. For this I created a program with a SoftMotion controller CODESYS Control for Linux SL. When I open the communications tab and scan the network, there are no devices found.

    I appreciate any suggestions on what I could try next. Thanks in advance!

     
  • eschwellinger

    eschwellinger - 2022-01-06

    if your are sure the runtime is up and running, I would recommend to install the edge gateway to scan the Linux SL...(add new Gateway in CODESYS with the ip of the linzx sl device and scan via this gateway

     
    πŸ‘
    1
  • muegggge

    muegggge - 2022-01-07

    Yes this worked better! I installed Gateway for Linux and also Control for Linux ARM64 SL (because I saw that it supports some features I want to use later). Then I changed the device to CODESYS Control for Linux ARM64 SL. It immediately found the industrial pc when scanning the network. Thanks!

     

Log in to post a comment.