Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Device User Logon Codesys Rpi

hanssmul
2021-11-01
2021-11-01
  • hanssmul

    hanssmul - 2021-11-01

    Hi,

    I have already seen this topic on severaL posts, however I haven't been able to solve my issue with it.

    I have installed Codesys 3.5 SP 17 patch 1 32 Bit on my windows 10 machine as well as Codesys Control for Rpi 4.2.00. All goes well up to te point where i trie to logon to load a Codesys project to the pi. At this point it prompts for User Name and password.

    What have I done/works fine:
    - Went on pi (with screen and mouse etc) to enable SSH
    - Installed putty, conected to pi with IP adres, username pi and password raspberry, works fine
    - Installed Tight VNC for remote acces, works fine
    - Installed Package Codesys Edge gateway for Lunux 4.2.00
    - Installed Package Codesys Control for Rpi 4.2.00
    - Used "Update RPi", Scanned IP with User pi and password raspberry, sees Rpi, Installes runtime to Rpi, application is running
    - Created a new standard Codesys project for Pi SL
    - Tried to logon to load project to pi.....thats when it prompts for Device user logon???

    To fix this I tried
    - Just about all suggested conbinations of passwords on forum
    - Tried to fill in IP adresses in communication settings, no difference
    - Edited CODESYSControl_User.cfg and changed [CmpUserMgr] to "SECURITY.UserMgmtEnforce=NO" no difference
    - Reinstalled Codesys + Codesys control for Rpi, no difference
    - Installed everything on another pc, same result
    - Tried connecting via cable and via Wifi, no difference
    - If I check Users and groups it is empty, clicking the sync button it tell me "Gateway not configured Properly"

    I'm lost here

    Can somebody give me the golden tip???

     
  • eschwellinger

    eschwellinger - 2021-11-01

    Hi,
    you do not know the credentials anymore which you have used on first login?

     
  • hanssmul

    hanssmul - 2021-11-01

    Hi

    Thanks for responing

    I was never asked to enter any credentials..
    Only thing that was asked for was to create an account on codesys to dowload the files.
    Just to be sure I repeated the whole thing on another fresh pc, just to check if i overlooked something which I didn't...

    Greetz, Hans

     
  • h-hermsen

    h-hermsen - 2021-11-01

    Sadly you are mistaking, the first connect with the runtime always asks you to enter a username and password once. When entered this username and password is now mandatory to download a sourcecode.

    This security behaviour is default enforced since SP17, was also avaible in previous CODESYS versions, but not enforced.

    Whenever you try to connect with that PLC you must enter the given username and password.

     

    Last edit: h-hermsen 2021-11-01
    • hanssmul

      hanssmul - 2021-11-01

      Is there a way to resolve this? I tried to edit CODESYSControl_User.cfg on Pi as suggested by users. This however did not help.

       

Log in to post a comment.