Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Beaglebone Black + Profinet Slave

Runtime
Anonymous
2020-02-20
2020-02-25
  • Anonymous - 2020-02-20

    Originally created by: jdadone

    Hello,

    I'm trying to connect the beaglebone with a robot KUKA by profinet.

    Beaglebone side:

    • I have already exported the gdsml file. The file name and version is:

           GSDML-V2.32-3S - Smart Software Solutions GmbH-Codesys PLC-20160824.xml
      
    • I have already added the codesys profinet device using a different project parameter, in my case beaglebone (it is
      the same in the robot)

    Codesys version: V3.5 SP15
    Beaglebone SL: 3.5.15.30 with softPLC license.

    Robot side:

    - I have imported and configured the gsdml.
    
    - I checked the connection with PRONETA and i can see the devices but it is imposible to make the connection.
    

    I don't know how to make it work.
    If it is possible to connect in slave mode, there are some steps or documentaton?

    Thanks in advance.

     
  • eschwellinger

    eschwellinger - 2020-02-20

    Hi,
    could you please use a USB-Ethernet Adapter for the Profinet interface?
    I think there is a problem with the local nic in BBB doing this.

    BR
    Edwin

     
  • i-campbell

    i-campbell - 2020-02-21

    In addition, Also check runtime configuration under profinet Io under field is under help.codesys.com (and all its subpages)

    There are some config steps for Linux runtime such as changing the protocol filter.

     
  • Anonymous - 2020-02-25

    Originally created by: jdadone

    I tried both. No succed.

    The maximum thing that i get was intermitent connection.

    I tried also modify the comm speed and the same result. Now with ethernet/IP i can communicate but with profinet nothing...

     
  • eschwellinger

    eschwellinger - 2020-02-25

    Hi,
    does a scan find your slaves? ( For the case that you are using an ethernet- usb adapter to do profinet)
    And could we get the plc log for that?
    BR
    Edwin

     

Log in to post a comment.