Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

onewire bus master stop working after upgrade

6 days ago
  • michelebianchi - 2023-04-06

    onewire stopped working after updating runtime to
    codesys control for raspberry pi
    codesys 3.5 sp19

    downgrading to runtime fix the problem

  • eschwellinger

    eschwellinger - 2023-04-06

    could you check if reading by cli does work? no changes on OS side?

  • augmue - 2023-08-06

    I made the update from to and have the same problem again.
    Few weeks ago I tried a other communication way with OWFS.
    Here I wanted to read the value from file /mnt/1wire/temperatur

    At least I found the problem that codesys blocks reading from files.

    I added the two lines in /etc/CODESYSControl.cfg



    Now it works again.

    Regard August

  • eschwellinger

    eschwellinger - 2023-08-06

    I would recommend to add your one wire path here:

    FilePath.1=/etc/, 3S.dat
    IecFilePath.1=/proc/, cpuinfo
    IecFilePath.2=/proc/, iomem
    PlaceholderFilePath.1=/sys/devices/w1_bus_master1, $OneWire$

    instead of changing the ForceIecFilePath setting

  • conny-nm - 2023-09-20

    Habe ein ähniches Problem Ethercat läuft nur mit RT nicht aber Onewire.
    Füge ich ForceFile läuft Onewire, nicht Ethercat. Bei IecFilePath.3 läuft Ethercat nicht aber Onewire

  • eschwellinger

    eschwellinger - 7 days ago

    du musst Onewire in einer eigenen Task aufrufen, das sind blockierende Aufrufe das geht nur in eigener Task, hab hier mal im Forum ein Beispiel gepostet


    Last edit: eschwellinger 7 days ago
  • augmue - 7 days ago

    ich lese alle 4 Sekunden einen Sensor DS18B20
    aus Datei im Verzeichniss /mnt/1wire
    mit USB-Adapter und owfs


  • conny-nm - 6 days ago

    Danke für die Hilfe habe ich übersehen. Habe zwischenzeitlich ein neues Betriebssystem aufgespielt und jetzt wieder meinen alten Fehler das die Runtime nur ca. 20 Sekund läuft.

  • eschwellinger

    eschwellinger - 6 days ago

    hm.. wie wäre es mit Runtime?


Log in to post a comment.