Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

STRANGE PROBLEM *** URGENT ***

Singh
2022-05-25
2022-05-29
  • Singh

    Singh - 2022-05-25

    Hello
    i am using Codesys 4.4.0.0 for Raspberry Pi ML
    I have more than 120 Devices. My Problem is 'Gerätebenutzeranmeldung'. I can access the device from windows 'Raspberry Pi'. I can upload device information. I can restart device, i use all functions. The moment i want to go online. The login windows comes. i enter the correct device login information. despite that i cannot login on device.

    i have used a new card with new image then i setup the device login. i could login. Then i reboot pi. I cannot login again.

    I also tried device reset. It doesnt help. Please help me. I am really disappointed.
    Regards
    Singh

     
  • Singh

    Singh - 2022-05-25
    1. WIth this window i can do all
     
  • Singh

    Singh - 2022-05-25

    but login with this window is making me insane now. as i am LOCKED OUT

    I have also tried to deinstall/reinstall Codesys it did'nt hekped
    Then i tried deinstall/reinstall+ All codesys folders deleted.
    THen it asked me new user setup. I did setup. it worked but next day, i have the same issue with the same device.

    Only thing which did was 'Licence wiederherstellung'

     

    Last edit: Singh 2022-05-25
  • Singh

    Singh - 2022-05-25

    I am trying to narrow down on the reason. i have now 7 pi's with same SD Card Image (naturally with different ip adrr and hostnames). They are running since last 3 Hrs. AND ARE ACCESSIBLE, Irrespective of countless Device ON-OFFs and Project Downloads. I have a feeling (not fact!), it has do with either
    1. order of files with which i rename my pi. /etc/hosts then /etc/hostname
    2. Lizenzwiederherstellung (Licence recovery!!)... As i have used the already licenced pi's. (I am managing a excel file where serialnumbers, ip addr and keys are listed. I am managing 120 devices...i need something like that)

    Now i will try to update the licence to see if it has to do with that!...

     

    Last edit: Singh 2022-05-25
  • eschwellinger

    eschwellinger - 2022-05-26

    The login via deployment tool and the user pi,
    is independent from the CODESYS login.
    If you'll be asked on first CODESYS Login to give a username and pw -
    these are the credentials then for the CODESYS login.
    See here the faq:
    https://faq.codesys.com/display/CDSFAQ/Disable+%28forced%29+device+user+management+as+of+SP17
    I'm sure this has nothing to do with licensing and to be honest I have never had
    a problem like that, but keep us informed how this could be solved.

     
  • Singh

    Singh - 2022-05-29

    Hello Mr. Schwellinger,
    Thanks for your help!
    in order to deactivate the device. I must be online. I tried the otherway around.
    I opened the /etc/CODESYSControl_User.cfg
    The Entry cmpuserMgr had no key like SECURITY.UserMgmtEnforce
    instead it had some Entry like AsymmetricAuthKey
    [CmpUserMgr]
    AsymmetricAuthKey=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX

    i, changed it to like
    [CmpUserMgr]
    SECURITY.UserMgmtEnforce=NO

    and rebooted:
    The System generates automatically the entry "AsymmetricAuthKey". And demands device User login despite!

    should i remove the whole codesys files etc. and then try ?
    I seems like information "Device User Login" is saved parallel in some other files too.
    Any suggestions?

     
  • Singh

    Singh - 2022-05-29

    And following entry is genarated auto. too !!
    [CmpSecureChannel]
    CertificateHash

     

    Last edit: Singh 2022-05-29

Log in to post a comment.