Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Problems with CODESYS Control for Wago PFC200 SL

Runtime
joostvb
7 days ago
5 days ago
  • joostvb

    joostvb - 7 days ago

    Dear CODESYS users,

    I recently bought a PFC200 (750-8212) Controller from Wago to use in a future home automation project.

    Since I want to control the device using CODESYS 3.5, I downloaded CODESYS Control for PFC200 SL from the CODESYS website. Following the manual that was included with the package, I successfully managed to install the CODESYS runtime on the device.

    Today (for testing purposes) I restored the original Wago runtime (using the SD card slot). After this I tried to re-install the CODESYS runtime, but I run into problems.

    Based on the Web Based Management page, it looks like the CODESYS runtime gets installed ok. However CODESYS is displaying an error when installing the runtime (see the screenshot below):

    However using 'Scan Network...' in CODESYS the device is not found and it looks like the runtime is not being started:

    I found an earlier topic on this subject https://forge.codesys.com/forge/talk/Runtime/thread/4f9b3dc8b7/ where a similar problem was described. In the topic it was stated that a possible cause for this problem is a shortage of memory on the device. A solution would be to remove the .deb packages install files. As described I checked the disk space using the ‘df’ command:

    However I’m not sure if this is the cause for my problem and if so how to find and remove the .deb packages install files (unfortunately my Linux knowledge is very limited).

    Could you please help me to solve this problem? Thanks!

    Joost

     

    Last edit: joostvb 7 days ago
  • eschwellinger

    eschwellinger - 7 days ago

    Hi,
    which firmware is on your PFC?
    At the moment there is a problem with FW 15... this will be solved with 3.5SP15Patch4. ( release will be next week)
    Will send out release candidate.
    BR
    Edwin

     

    Last edit: eschwellinger 7 days ago
  • joostvb

    joostvb - 6 days ago

    Hi Edwin,

    Thanks for your very quick response!

    I indeed use firmware version 03.03.10(15) on my PFC.

    I received the ipk release candidate 3.5SP15Patch 4 via e-mail. I deployed it to the PFC and the problem that I encountered is now solved. Thanks!

    I also encounter another small (but very annoying) problem. When in the CODESYS Web Based Management a Static IP address is entered in the IP Configuration setting, the IP-address is correctly altered. However after a controller reboot, the configuration type is reset to ‘DHCP’. Is this also a known problem with this firmware? Maybe I’m missing a setting to ‘store’ the setting in the controller?

    Thanks for your help!

    Joost

     
  • eschwellinger

    eschwellinger - 6 days ago

    HiJoost,
    No, never seen.
    Could you try to split/seperate the nic's and check If this then works
    BR
    Edwin

     
  • joostvb

    joostvb - 5 days ago

    Hi Edwin,

    Separating the NIC's did the trick! Learning step by step, great fun ;)

    Thanks for your excellent support!

    Joost

     

Log in to post a comment.