• Anonymous - 2019-09-07

    Originally created by: phenixrb

    Hello everyone,
    I noticed problems between the latest version of raspbian and codesys, after an update of raspbian.

    defects found:
    no connection pc / pi.
    no webvisu.
    no raspberry reboot
    and freezes raspberry.

    I think this stems from a conflict between the management of the codesys and rasbian I2C service.

    I did the following tests:

    "The reboot requests are all from the raspberry and not from the codesy interface on PC"

    first test:
    raspbian installed: reboot OK
    then, raspbian update: reboot ok
    then, raspbian upgrade: reboot ok
    then, SSH, VNC, SPI, I2C services active: reboot ok.
    then, installation of runtime codesys: reboot requested, the raspberry turns off but never turns on again.

    second test:
    raspbian installed, update, upgrade, no VNC, SPI, I2C.
    the SSH service is active.
    runtime installation codesys: reboot ok
    installing the codesys license: reboot ok
    start runtime on raspberry: reboot ok
    loading a codesys program into the raspberry: reboot ok
    running the codesys program in the raspberry: reboot ok
    start SPI service in raspberry: reboot ok.

    SPI and I2C active in the raspberry the start of the codesys program in the raspberry:
     -no connection between the PC and the raspberry,
    -and reboot the raspberry asked, the raspberry turns off but never turns on again.

    SPI and I2C active in the raspberry running the codesys program in the raspberry: reboot ok

    third test:
    Starting the raspberry with SPI and I2C services enabled before reboot:
    running request of the codesys program on the raspberry:
    no pc / raspberry connection.
    no webvisu
    and after that, it freezes raspberry.

    fourth test:
    runtime codeys installation

    when the services: SSH, SPI and I2C are active on the raspberry, it is almost impossible to install the codesys runtime.
    and when it's possible after several minutes of waiting,
    the reboots are degraded, as before.

    by enabling only SSH installation is possible.

    that's what I see, I'm not a pro of lines of codes, far from it ....

    if you have some ideas to follow, I'm interested.
    thank you

  • eschwellinger

    eschwellinger - 2019-09-07

    all this should be solved hopefully with the release of 3.5SP15Patch1 on September release.
    Will send you a release candidate to check.


  • Anonymous - 2019-09-07

    Originally created by: phenixrb

    hello Edwin,

    I thought I was the only one to be faced with this problem.
    waiting for the fix.

    thanks for the answer,

  • Anonymous - 2019-09-07

    Originally created by: phenixrb

    the patch seems to have solved the problems:
    with runtime package in raspberry
    and codesys control for the device , wasn't in the list.

    with active SPI and I2C services.
    reboot raspberry from the pc: ok
    reboot from raspberry: ok
    PC / PI connection: ok
    webvisu: ok
    no raspberry freezes

  • fixstuff555

    fixstuff555 - 2019-09-08

    I see that the patch isn't in the store yet? Any ETA on this?

  • eschwellinger

    eschwellinger - 2019-09-08

    19th of September is the release date for 3.5SP15Patch1


  • elconfa

    elconfa - 2019-09-13

    I will wait for the update because after having struggled 2 days to update Raspberry 3 with the new 3.5SP15 runtime that I use for my home automation, I had to go back to the 3.5SP14 version, otherwise nothing worked.

    I thought it was my problem, I tried with Raspberry pi-0W, with raspberry pi3B + but enabling it i2c nothing worked anymore.

    I am happy that an update will be released in the coming weeks.



Log in to post a comment.