can two different OPC server share same port?

shakir
2020-11-04
2020-11-11
  • shakir

    shakir - 2020-11-04

    I am trying to connect robot controler CODESYS program with OPC Expert through OPC UA server and that's listening 4840 port and on OPC Expert I'm getting like opc.tcp://hp-nb:4840/uadiscovery. I also installed freeopcua in my machine and that's listening 4840 port as well and on OPC Expert it's like opc.tcp//0.0.0.0:4840. On OPC Expert I need to connect with CODESYS application. I can connect with CODESYS OPC server but I'm not able to connect my application from CODESYS controler. Is it happening because of two servers are listening on same port? if not then how can I resolve my issue? Attached an image of my issue

     
  • dFx

    dFx - 2020-11-09

    Wikipedia says :
    In computer networking, a port is a communication endpoint. At the software level, within an operating system, a port is a logical construct that identifies a specific process or a type of network service.

    This means that a port is more or less an ID. So you can't share the same port between two different software on the same machine.

    You should be able to change OPCua port in your controller OPCua settings.

     
    • shakir

      shakir - 2020-11-10

      I solved that issue of sharing two servers on same port but still I'm not able to connect my application from CODESYS Controller through OPC. I can connect my Ua Expert or OPC Expert with my CODESYS program through OPC UA server. But the issue I got that OPC server can't browse my CODESYS program application. Did I miss anything? I have tried in so many ways but nothing worked out so far. Attached Ua Expert browsing failure image

       
  • eschwellinger

    eschwellinger - 2020-11-10

    ..did you add symbol configuration in your CODESYS project?

     
    • shakir

      shakir - 2020-11-11

      Yeah I added symbol configuration. I followed the following link: https://help.codesys.com/api-content/2/codesys/3.5.14.0/en/_cds_runtime_opc_ua_server/

      I tried in every possible way but it didn't work. I can connect with my Digital twin in Visual Components but for data encryption with Ua Expert or OPC Expert, COdesys OPC server can't browse it's application.

       

      Last edit: shakir 2020-11-11

Log in to post a comment.