Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Bought a license, but can't activate

  • rotemse

    rotemse - 2019-08-14

    I bought a license,
    Payment Id: rl4UYEbAhA6OtAIvbS91Ah4WzjEb
    raspberry pi with the new firmware V3.5.15.0

    but when I try to install the license I get the error:
    "10957 ticket contains no open licenses for this firmcode"

    In the License repository it says "delivered"

    But in the license manage, I see the softcontainer Id, but all the fields are blank.

    IMG: Capture4.JPG

    IMG: Capture3.JPG

    IMG: Capture2.JPG

    IMG: Capture1.JPG

  • rotemse

    rotemse - 2019-08-14

    Now I am sure the license was not activated, because the runtime was terminated after 2 hours.
    I can't install the given license due to the error I posted above.

    What can I do now?

  • eschwellinger

    eschwellinger - 2019-08-14

    I have send out the license update file,
    which you could use for the reactivation for this PI.

    Sure the licensing is done that way:

    If you use current version you have the licensebackupfile on your PC ( the one you have used for the activation of the license)


  • ctgarvey

    ctgarvey - 2020-01-17

    hi Edwin,
    i have same problem. Had to completely rebuild Raspberry Pi after SDcard fail - and softcontainer failed with it. When i went to license the same Pi again, i got:

    10957 - ticket contains no open licenses for this firmcode

    I can PM the ticket Id to you. Pi hardware is identical, new SD card. Looks like softcontainer approach to licensing doesnt behave the way other PLC / software licensing does and based itself on the hardware (some licensing takes a note of the ethernet MAC or CPU ID address for example, so that it may be installed to same system at a later date, in the case of complete rebuild)

    Best regards,

    IMG: CantReLicense.png

  • i-campbell

    i-campbell - 2020-01-17

    Sounds like you're using the "activate new license" workflow instead of "restore old license" workflow. Check the help page here for what you need:

    https://help.codesys.com/webapp/_cds_in ... -a-license

    You said "Looks like softcontainer approach to licensing doesnt behave the way other PLC / software licensing does and based itself on the hardware..."
    Actually it does. Don't worry, you can restore it to the same hardware.

    This FAQ has some troubleshooting info, for example if the softcontainer has been copied from another PLCs SD card.
    https://faq.codesys.com/pages/viewpage. ... Id=1310825 m

  • notchback

    notchback - 2021-08-10

    Hi Edwin,

    I have encountered the exact same issue as above, I have reset the rpi, and also no longer have access to the PC that first installed the license on the Rpi 3.
    So i have no license backup file. What can i do?
    Thanks for your time.

    Order No. 200004885


    Last edit: notchback 2021-08-10
  • eschwellinger

    eschwellinger - 2021-08-10

    even if you not have it...you could restore it help.codsys.com - Raspberry Pi licensing..or contact the CODESYS support by the store bug report.

  • notchback

    notchback - 2021-08-11

    Hi Edwin,

    Restoring the ticket gave the following result;
    License could not be restored automatically. Please contact our support department. Reason: Cant reload license update file from server.
    Have lodged a report with the store, will reply if i get a solution.

    Cheers from NZ!

  • jreitzig

    jreitzig - 2021-12-11

    Hi, has this ever been solved? I purchased a ModBus TCP license but also fail to install it with the same error. Note, I haven't licensed the RPI runtime yet. This is one is still running with the 2h timeout. Would this be a prerequisite for any other features to be licensed (which expire already after ~20min).
    Thank you!


Log in to post a comment.