Logging to a SoftPLC remotely?

  • epinikion

    epinikion - 2020-09-14

    Hi all,

    One of the machines in the company I work for had no backup for quite a few years, so I tried to log in and do one myself, unfortunately I can't seem to find the device through my computer. It's a Visu-PC with RTE V3 installed, so maybe I should open CodeSys directly on the HMI, instead of trying to find it through my laptop? Until now I worked with just normal PLCs so I'm not sure. I checked the manual for RTE V3 and they seem to do such things with CodeSys too. Any tips? Any recommended documents to check?

    Thanks in advance!

  • epinikion

    epinikion - 2020-09-14

    Hello again,

    I actually managed to connect. But when I try to upload the source code to my PC and select the device, I get the following error: "no source archive available on the plc". Theorically I can get the source code on RUN, right? Or do I need to stop it? Does it work differently for SoftPLCs and HMIs?

  • eschwellinger

    eschwellinger - 2020-09-17

    this is just an options to download the source code of an application to the plc - and the default
    is not to do it.
    So I assume there is no source code on the plc.

  • epinikion

    epinikion - 2020-10-02

    Thanks for the answer.

    What would be the next step then? When I compare my code (allegedly last uploaded version) with the one on the PLC there's a lot of stuff changed since last download, hence why I can't go online. The date doesn't match either. Last project is from June and the one on the PLC from December.
    It seems to do with the visudialogs library, but I have the same version installed (I extracted it from the project anyways).

    Attached are some snippets of the application comparison. Is there even any hope, or does all the not matching stuff need to be reprogrammed again?


Log in to post a comment.