Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

[HELP] Connecting Codesys v2.3 program with a Codesys HMI SL project in V3

pedro-ant
2017-05-04
2021-10-18
  • pedro-ant

    pedro-ant - 2017-05-04

    Hi everyone,

    I'm trying to make a little proof of concept with this setup:

    • I make a silly program in Codesys v2.3 with an XC-CPU201-EC256K from EATON as Target.
    • I simulate the PLC with Codesys v2.3.
    • I make a HMI project with Codesys Development System v3 in order to create a visualization of the PLC that works with Codesys HMI SL (like shown in this webinar https://youtu.be/mIvH7L6U5P0).

    But I can't add the PLC as Datasource to the HMI project. I've tried changing the Communications Parameters but I don't know how to link the simulated PLC with the HMI project.

    Here you can see two screenshots of the situation:

    I would be very grateful if someone point me in the right direction.

    Thank very much in advance for your help.

    IMG: Bild

    IMG: Bild

     
  • eschwellinger

    eschwellinger - 2017-05-05

    Hi,
    hm.. you write:

    Zitat:
    '- I simulate the PLC with Codesys v2.3.'

    this is the point I guess.
    You need to use a real plc, even if it is running under Windows for example PLCWinNT which is part of the CODESYS V2.3 installation .
    Then it should work

    BR
    Edwin

     
  • pedro-ant

    pedro-ant - 2017-05-08

    I've just tried with PLCWinNT and now it works.

    Thank you very much, Edwin.

     
  • keluangman

    keluangman - 2021-10-18

    Hi, I have the same problem with the symbol configuration from Codesys V2.3. I have a PLC from Wago 750-880. Im not sure why the Codesys HMI cant read the data from Codesys 2.3. What Ive notived the difference between Codesys V3 and V2 is the .xml (Codesys V3) and .sym_xml (Codesys V2) for the symbol configuration. I think because of this sym_xml file, the Codesys HMI cant read the values from Codesys V2

     

Log in to post a comment.