PFC200 FW15 läuft nicht

Deutsch
Chris.O
2019-12-20
2020-05-25
  • Chris.O

    Chris.O - 2019-12-20

    Hallo,

    da vom BSI eine Sicherheits-Warnung für PFC200 und PFC100 raus ging, muss man laut WAGO das Update auf FW15 durchführen.
    Hab das mal mit V3.5 SP15 Patch 2 Probiert... Laufzeitsystem installiert, kann aber anschließend die PFC nicht im Projekt finden.

    Könnte man das im nächsten SP mit aufnehmen?! Wann würde das kommen?

    Gruß

    Christian

     
  • annD

    annD - 2020-04-04

    @i-campbell: Dein Hinweis war richtig!

    Nach dem Setzen von serialmode rs485 hat es sofort funktioniert. Ich habe mich täuschen lassen, weil durch Abfrage von serialmode bereits rs485 angezeigt wurde.

    Danke und schöne Grüße,
    annD

     
    👍
    1
  • eschwellinger

    eschwellinger - 2019-12-21

    Hallo Christian,

    ja sind dran...!

    Grüße
    Edwin

     
  • annD

    annD - 2020-01-24

    Hallo Edwin,

    wurde das in 3.5.15.30 bereits behoben oder dauert es noch länger?

    Schöne Grüße,
    annD

     
  • eschwellinger

    eschwellinger - 2020-01-24

    Hi,
    sorry nein, das ist leider noch nicht drin..!

    Grüße
    Edwin

     
  • almot89

    almot89 - 2020-02-12

    stehe vor dem gleichen Problem...…

    meine PFC hat mit der alten 02.08.31(11) plötzlich keine karten immer im Kbus gefunden. auch ein wiedereinspielen der alten Firmware von SD Karte und der Einsatz von E!cockpit brachte kein erfolg.

    seit dem Update auf FW 15 läuft der Kbus wieder...… warum auch immer.... nur leider die codesys runtime nicht

     
  • eschwellinger

    eschwellinger - 2020-02-12

    Hi,
    ihr könnt eine Vorabversion (sobald verfügbar) haben in 3.5.15.40 ist das dann behoben.

    Grüße
    Edwin

     
  • almot89

    almot89 - 2020-02-17

    Hallo Edwin,

    es eilt bei mir nicht, hab erstmal wieder das Raspberry aus der Schublade geholt..... aber wenn es keine Umstände macht, kannst du mir ja die Vorabversion zukommen lassen. dann kann ich mal testen ob die PFC 200 jetzt wieder richtig läuft.

     
  • annD

    annD - 2020-04-04

    Hallo Edwin,

    ich habe jetzt mein Projekt vom alten PFC200 auf die G2 mit FW15 gewechselt und mit 3.5.15.40 läuft es soweit. Auch die ganzen Netzwerkfunktionen z.B. aus der Oscat Network werden problemlos ausgeführt.

    Seltsamerweise bekomme ich aber keine Verbindung zum Modbus RTU Zähler über die serielle Schnittstelle. Die Software ist unverändert zum alten PFC und ich habe einfach nur das Kabel an den neuen Controller gesteckt. Die Schnittstelle war über die SPS-Shell schon auf RS485 gestellt und in der Webvisu als "Unassigned" definiert. In Codesys ist es nach wie vor Port 1, oder? In Codesys wechselt die Fehlermeldung immer zwischen "undefined" und "no response". Was kann ich noch kontrollieren?

    Gruß annD

     
    • i-campbell

      i-campbell - 2020-04-04

      Ja, SPS-Shell sagt es ist schon rs485. Aber, probieren Sie einmal mehr rs485 setzen.
      G, Ian

       
      👍
      1
  • eschwellinger

    eschwellinger - 2020-04-04

    Was hattest du vorher für eine Runtime Version laufen?

     
    • annD

      annD - 2020-04-04

      Es war vorher 3.5.14.0. Ich könnte den Controller nochmal testweise in
      Betrieb nehmen.

      Lg

       

      Last edit: annD 2020-04-04
  • eschwellinger

    eschwellinger - 2020-04-05

    entscheidend ist welche Wagofirmware auf dem alten Gerät war.
    Ich denke nach FW12 hat sich die serielle Schnisttelle geänder im Linux OS,
    allerdings müsste das wenn du SP15Patch4 und FW15 verwendest passen.
    Aber kannst ja trotzdem mal noch mit
    cat /etc/CODESYSControl_User.cfg
    dein Konfigfile hier anhängen.
    Wenn das alles passt mal im aktuellen CODESYS die Mobus Libs runter auf SP14... letzter Versuch wenn die Physik (serial MAPPING zum Cpomport stimmt.

    LG
    Edwin

     
  • annD

    annD - 2020-05-25

    Der Tipp von i-campbell war goldrichtig! Das nochmalige Setzen von rs485 (trotz der bestehenden rs485 Rückmeldung) war erfolgreich.

    @eschwellinger: Kann man die Wago FW16 mit Codesys 3.5.16.0 bedenkenlos verwenden? Oder sollte man besser noch abwarten?

    Gruß annD

     

Log in to post a comment.