Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

EWON

Anonymous
2017-08-14
2019-05-06
  • Anonymous - 2017-08-14

    Originally created by: ph0010421

    Hello
    I'm having problems connecting to my Codesys PLC through an Ewon Cosy. I can see other parts of the target (it's an HMI/FTP server aswell).
    Is there an option I need to set?
    thanks

     
  • timvh

    timvh - 2017-08-18

    Don't use the "Scan for devices", because you have probably created a VPN tunnel and this doesn't work.
    You have to use TCP/IP communication, therefore just enter the IP address of your CODESYS Controller in your communication settings dialog. Then it will try to connect by TCP/IP with the controller.

     
  • Anonymous - 2017-08-19

    Originally created by: ph0010421

    Thank you.

     
  • eschwellinger

    eschwellinger - 2017-08-19

    Hi,
    there is a known error with current Gateway ( you need to use as a workaround <SP10 CODESYS Gateway - will be fixed to 3.5SP12)

    BR
    Edwin

     
  • Anonymous - 2017-08-19

    Originally created by: ph0010421

    Thank you, too.

     
  • GPezzolato

    GPezzolato - 2019-05-06

    TimvH hat geschrieben:
    Don't use the "Scan for devices", because you have probably created a VPN tunnel and this doesn't work.
    You have to use TCP/IP communication, therefore just enter the IP address of your CODESYS Controller in your communication settings dialog. Then it will try to connect by TCP/IP with the controller.

    Hello, I'm new in this forum and I'm a new user of the codesys 3.5.
    Last week I installed the version 3.5 SP14 Patch 2.
    I have the same problem with eWON Cosy, but probably I'm not setting the right parameters/address. How can I connect without the "scan for devices" ?
    I can only connect to the device directly (ethernet cable from pc to device) and with Gateway "localhost".
    Thank you

     

Log in to post a comment.